Safari always opens things in new windows.

Discussion in 'Mac Apps and Mac App Store' started by Boesky, Jul 23, 2009.

  1. Boesky macrumors 6502

    Joined:
    Jul 16, 2009
    #1
    When i click on a link, how do i make it so it opens in a new tab. not a new window?
     
  2. guydude193 macrumors 6502a

    Joined:
    May 15, 2009
    Location:
    MI
    #2
    Safari Preferences> General Tab. Once there, look at the bottom of the window and there should be 2 bubbles. Select the one that says 'In a new tab'.
     
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    I had to do this to my Safari. But I found the answer to this question with a simple google search of "force safari to open in new tab". It was easy. :D

    linky
     
  4. Boesky thread starter macrumors 6502

    Joined:
    Jul 16, 2009
  5. guydude193 macrumors 6502a

    Joined:
    May 15, 2009
    Location:
    MI
    #5
    Somewhere in your toolbar, you'll find a preferences type thing. You should find it eventually. :p
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    To access Safari preferences on Safari for Windows, at the end of your address bar is the icon of a gear. Click on the gear icon, then navigate to preferences. Alternatively if you have the menu bar enabled (File, Edit, View, History, Bookmarks, Window, Help) you can navigate to preferences under the Edit menu. As a previous poster noted, go to the general tab in Safari preferences, and click the bubble for "Open links from applications: in a new tab in the current window"

    Actually, I just re-read your initial post...When you refer to "click[ing] on a link," is this from an email or you mean when you click on a link in a website you are browsing you want it to open in a new tab? Only way I know to do the latter is to hold down on the crtl+alt keys and click on a link or crtl+click depending on the preferences you set in the Tabs preferences of Safari.
     
  7. Meek Wriggle macrumors member

    Joined:
    Jun 10, 2009
    Location:
    UK
    #7
    This is the main reason I don't use Safari. In order to properly open a link in a tab you have to right click the link and select the option to open in a new tab. I'm not really sure why Apple haven't fixed this yet because, if it wasn't for this problem, Safari would be a great browser.
     
  8. Boesky thread starter macrumors 6502

    Joined:
    Jul 16, 2009
  9. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #10
    Launch Terminal (in HD > Applications > Utilities) & type (or copy & paste) this:

    defaults write com.apple.Safari TargetedClicksCreateTabs -bool true

    then press return & restart Safari.
     
  10. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #11
    Apparently for Windows there is no way to set this as the default behavior.
     

Share This Page