Safari and iTunes Issues

Discussion in 'Mac Basics and Help' started by yanksfanry, Dec 21, 2007.

  1. yanksfanry macrumors newbie

    Joined:
    Dec 21, 2007
    #1
    Alrighty, so I have a 15" PowerBook. 1.5 GHz PowerPC G4, 512 MB. I know little about computers.

    Safari, iTunes and MSN Messenger will not open on my computer. Safari has been doing this for a while, iTunes and MSN just since yesterday. When I click on the logos, they will bounce in the toolbar and then just stop. The log that I somehow found earlier reports them as crashing.

    Any tips? I can live without Safari, but no music is killing me... Any suggestions would be greatly appreciated and if you need any info on the system I will do my best with that.

    Thank you so much.
    And if it helps you want to help me... today's my birthday. AND my car broke down earlier. So awesome day.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Happy birthday!

    Were these apps ever working properly? If so, what changed before they broke? Also, create a new user account in System Preferences and see if the problems occur there, too. :)
     
  3. skyrider007 macrumors 65816

    skyrider007

    Joined:
    Aug 5, 2007
    Location:
    Bangkok
  4. yanksfanry thread starter macrumors newbie

    Joined:
    Dec 21, 2007
    #4
    For iTunes this shows up in the console crash report:


    Host Name: Ryans-Computer
    Date/Time: 2007-12-21 08:51:28.706 -0800
    OS Version: 10.4.11 (Build 8S165)
    Report Version: 4

    Command: iTunes
    Path: /Applications/iTunes.app/Contents/MacOS/iTunes
    Parent: WindowServer [490]

    Version: 7.5 (7.5)

    PID: 538
    Thread: Unknown

    Link (dyld) error:

    Symbol not found: _WebCoreUnicodeDirectionFunction
    Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
    Expected in: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore

    Any ideas?
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Have you tried the new user account? Maybe try reinstalling the 10.4.11 combo update as it looks like a missing component of Webkit may be the cause, or at least one of the causes. :)
     
  6. yanksfanry thread starter macrumors newbie

    Joined:
    Dec 21, 2007
    #6
    Thanks for the suggestions, I am downloading that piece now.

    I tried the new user before, that did not work.
    I've tried repairing permissions, deleting preference files and I ran maintenance scripts. I have not yet "Zapped the PRAM".

    Any other tips? Thanks again.
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    Well, something like an Archive & Install may help. Try the combo update first though. :)
     
  8. yanksfanry thread starter macrumors newbie

    Joined:
    Dec 21, 2007
    #8
    Note: So I downloaded the update and when it tries to open it with Installer, Installer shuts down. Awesome...
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    No error message? Maybe back everything up and try the Archive & Install then...
     
  10. yanksfanry thread starter macrumors newbie

    Joined:
    Dec 21, 2007
    #10
    I dunno if this means much, but I figured I'd try and go around the problem and get an alternative to iTunes. So I downloaded the music player "Play" and that won't open either, doing the same thing. AHhhh!
     
  11. yanksfanry thread starter macrumors newbie

    Joined:
    Dec 21, 2007
  12. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #12
    It's this, mate. It should keep everything intact but it's a good idea to back it all up in case it gets hairy. It basically ignores your files and settings, collects up your system, dumps it in a folder and then installs a new one over the top. :)
     
  13. yanksfanry thread starter macrumors newbie

    Joined:
    Dec 21, 2007
    #13
    Thank you very much, I will give that a shot later.

    I have collected all of my photos onto CDs. But what is the best way to save my music? Thanks again!
     
  14. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #14
    Assuming you use iTunes and let it manage your music, then make a copy of your iTunes folder. It's that simple. :)
     

Share This Page