Safari and MSN Hotmail problem

Discussion in 'Mac Apps and Mac App Store' started by slunky, Oct 22, 2007.

  1. slunky macrumors newbie

    Joined:
    Aug 2, 2006
    #1
    Until recently I had no trouble opening MSN Hotmail in Safari. Now when I try, several addresses bounce back and forth until it loads a page saying
    Windows Live ID is unavailable from this site for one of the following reasons:
    This site may be experiencing a problem.
    The site may not be a member of Windows Live ID.
    You can:You can sign in or sign up at other Windows Live ID sites and services, or try again later at this site.
    Windows Live ID
    Works with Windows Live, MSN, and Microsoft Passport sites
    Account Services | Privacy Statement | Terms of Use
    ©2007 Microsoft
    I have tried loading Hotmail's page from every angle I can think of; from bookmarks, MSN's homepage, MyMSN, etc.
    I have no such issue with Firefox. It loads fine in Firefox.
     
  2. paulwells73 macrumors newbie

    Joined:
    Feb 19, 2007
  3. spoongibbon macrumors newbie

    Joined:
    Jun 26, 2006
    Location:
    Dublin, Ireland.
    #3
    Same here. it seems to have happened after the last Messenger update.
     
  4. shagadelic45200 macrumors newbie

    Joined:
    Mar 26, 2007
    #4
    i have the same problem....the only work around i have found is to delete the cookies from safari (safari-preferences-show cookies-remove all) and then it works, but you have to do this ALL THE TIME!

    would be nice if there is a premanent fix, anyone?
     
  5. terrielicious macrumors newbie

    Joined:
    Nov 4, 2007
    #5
    i went to the mac store and a genius told me its a problem that microsoft is trying to fix. I think its just cause microsoft sucks lol no but really its been the past few weeks and i suggest although annoying just use firefox because it works. that was his recommendation as well. k? <3:apple:
     
  6. terrielicious macrumors newbie

    Joined:
    Nov 4, 2007
    #6
    he also said it should be fixed soon. there's nothing we can do from our end of the computer screen to fix the problem so sit back and enjoy the annoyance.
     
  7. Kiki71 macrumors newbie

    Joined:
    Jan 9, 2008
    Location:
    Jakarta, Indonesia
    #7
    I have exactly same problem like Mr.Slunky. I hope this problem will solve soon.
     
  8. thumper macrumors 6502

    thumper

    Joined:
    Oct 25, 2003
    Location:
    Under the Sea
    #8
    i have the feeling this is a bug mircosoft made for safari...
    its been going on for way too long... and its funny only safari doesnt work with hotmail...
     
  9. Agurri macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #9
    Hum, I had this problem, and I found a solution:

    1. You have to install the debug menu in Safari. First, you have to close Safari, then in terminal, apply this command :

    defaults write com.apple.Safari IncludeDebugMenu 1

    (If you ever want to disable the menu, just re-apply the command with 0 instead of 1).

    2. Restart Safari; now you should see the debug menu on top.
    3. Go to your hotmail account, and when you are on the error page, just go in the Debug menu -> User Agent -> Windows MSIE 6.0.

    This should do it.... post back if you have any problems
     
  10. abqsammy macrumors newbie

    Joined:
    Jan 14, 2008
    #10
    works!

    I have Safari 1.3.2, and your ftx works well.
    many thanks!
    Sammy
     
  11. genedi macrumors newbie

    Joined:
    Jan 30, 2008
    #11
    Hi Agurri,

    could you please be more specific (sorry, I'm really bad with computers and have just switched from PC to Mac and I'm a bit lost here) ! :eek:
    Don't know where to apply the command you speak of ! Also, where is the "debug menu" ?
    Sorry for asking what are probably very stupid questions but I have no other way to learn (my husband is a "PC man", he was the one to help me out when I had a problem, now that I have a Mac he tells me "you wanted a Mac, now deal with it" !!! :rolleyes: (He's just jealous !) :D
     
  12. nwriko macrumors newbie

    Joined:
    Sep 11, 2007
    #12
    Safari and MSN Hotmail problem

    does this help you?

    Open the Terminal program, which you'll find in the Applications_Utilities folder. Once launched, Terminal opens a single window displaying a greeting and a second line of text that comprises the prompt. With that window active, anything you type will enter just before the rectangular cursor that follows the prompt. After you type a command, simply press Return or Enter to run it.
     
  13. genedi macrumors newbie

    Joined:
    Jan 30, 2008
    #13
    Hello nwriko,

    Yes, thank you (could never have found it alone :eek:) except that when I enter the command, I get a message "command not found" ! ???

    Uhhhhh, what should I do now ??? :confused:
     
  14. Agurri macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #14
    Make sure you quit Safari. Copy/Paste the command. It should work....
     
  15. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
  16. genedi macrumors newbie

    Joined:
    Jan 30, 2008
    #16
    :D Thank you all so much for your help, don't know what I did different from the 1st time but now it works fine (thanks to the debug which is now installed and allowed me to open my hotmail where it used to endlessly try to load without success), again thank you for your help !!!

    Genevieve :D
    (A proud and happy Mac user) !
     
  17. BlakTornado Guest

    BlakTornado

    Joined:
    Apr 24, 2007
    Location:
    Washington, OH
    #17
    Wait. Does that do what I think it does? (Change Safari to mimic another browser)

    Because that would be incredibly useful if it did...
     
  18. iCeFuSiOn macrumors 6502a

    Joined:
    Jul 18, 2007
    #18
    Yes, it changes the user agent that the browser reports to the server, so that the server thinks you're running a different browser.

    I've noticed that if you don't set Windows Live ID to save your password, then this issue doesn't occur (so if you set it to remember username only for example).
     
  19. Agurri macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #19
    Yes, but be careful. Some things doesn't work when you mimic-ing MSIE 6.0. i.e. when you're in hotmail, you can't click on links.... so I only use it to load hotmail



    Yea, but this trick is very useful if you aren't the only one using the computer.
     
  20. hwojtek macrumors 6502a

    hwojtek

    Joined:
    Jan 26, 2008
    Location:
    A small rural village in western Poland
    #20
    I had this problem on two computers (PPC and Intel) and the cookie bug in ICBM version of Safari helped me to resolve it in a different way. It works ever since and is dead simple:
    1. delete all cookies set by hotmail.com and live.com
    2. quit Safari and launch it again.
    3. login to Hotmail, making sure you only store you username (account) and not the password.

    The other workaround (but this time it works the problem around in a really big circle) is to use the "Account settings" (or similar, can't remember now) link in the Hotmail failed login screen. It allows a proper login on next screen, and if you typed www.hotmail.com in Safari address bar, it will open up your email folders without the need for login this time (the Live login is kept in the browser as long as it is not closed).
     
  21. BlakTornado Guest

    BlakTornado

    Joined:
    Apr 24, 2007
    Location:
    Washington, OH
    #21
    Well I was thinking more for testing out my website :) Since I don't actually have Internet Explorer ready at hand, this is really useful because I don't design my website to be Explorer compatible - just FireFox and Safari... so thus i end up having to put a javascript message saying "This site may not work properly with internet explorer. Sorry"... so that's why this is useful for me :)

    Thanks a bundle for sharing it!
     
  22. captkirk macrumors newbie

    Joined:
    Feb 19, 2008
    #22
    I am new to mac also- your fix worked great! Thanks for the great info!
     
  23. josdie macrumors newbie

    Joined:
    Apr 21, 2008
    #23
    Hotmail and my mac

    Hiya,

    I'm just a dutch bimbo and am unfortunately not able to understand your solution to the hotmail-not-opening problem. I got as far as opening terminal and puting in: defaults write com......etc. then i pressed enter/return and the termiinal did it's thing which is like chinese for me (nope, dutch people can't speak chinese either). After I opened Safari again I just couldn't find that deBug menu you are telling me about... What am i doing wrong!

    Please help me....

    Ta
     
  24. Agurri macrumors 6502

    Agurri

    Joined:
    May 8, 2005
    Location:
    Québec, Canada
    #24
    josdie,

    First, make sure Safari is quit. Second, when you enter the command defaults write com.apple.Safari IncludeDebugMenu 1, you should not see any confirmation.
    I joined a picture of what you should expect.

    Report back if you still have problems.

    PS. You can also try to reboot. Never hurts.
     

    Attached Files:

  25. christine82126 macrumors newbie

    Joined:
    Jun 10, 2008
    #25
    I can't get the debug menu to appear.

    I have followed the directions exactly and rebooted as well... I just can't seem to get the debug menu to appear.
    I dont know if you might be able to help me.
     

Share This Page