Safari and Netflix

Discussion in 'Mac Apps and Mac App Store' started by gophers2010, Sep 17, 2011.

  1. gophers2010, Sep 17, 2011
    Last edited: Sep 19, 2011

    gophers2010 macrumors newbie

    Jun 29, 2010
    I tried to log onto netflix today only to be greeted by the message

    "Safari's Private Browsing mode is restricting Netflix from storing settings on your computer."

    However, I do not have private browsing on. I have tried restarting my computer, uninstalling and reinstalling the required plug-in for Netflix and have even tried using firefox and chrome.. all to no avail. Does anyone know how to fix this? The error code netflix gives me is N8010, and I use an airport express base station for my wifi.

    Thanks in advance!


    I made a guest account and logged onto that to see if netflix would work, and it booted up no problem. Still no success in launching it on my main account however.
  2. miles01110 macrumors Core


    Jul 24, 2006
    The Ivory Tower (I'm not coming down)
    What happens when you use Firefox or Chrome? Presumably it doesn't tell you that Safari's Private Browsing is interfering.
  3. Gillespie81 macrumors regular

    Sep 2, 2011
    huh. I've been on netflix a few times in the past couple days and logged in and watched movies just fine. also no problems with hulu either
  4. gophers2010 thread starter macrumors newbie

    Jun 29, 2010
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_3 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    Firefox also tells me to disable private browsing. And I think chrome told me more or less the same thing.

Share This Page