Safari and PDF

raiempire

macrumors newbie
Original poster
Jun 10, 2005
2
0
Before I installed Tiger OS, PDF files would open up preview. This allowed me to easily save the document to the desktop.

After installing Tiger OS, PDF files are opening up in safari browser making it more difficult to save. I need to hit "print largest frames" to save it as a pdf to desktop. This seems to sometimes cause compatability issues with pdf file when i open it on different computer and operating systems.

I haven't been able to find a option to make all pdf files open in preview rather than web browser. Was wondering if anyone had any insight into this issue.
 

stridey

macrumors 65816
Jan 21, 2005
1,136
0
Massachusetts, Connecticut
raiempire said:
Before I installed Tiger OS, PDF files would open up preview. This allowed me to easily save the document to the desktop.

After installing Tiger OS, PDF files are opening up in safari browser making it more difficult to save. I need to hit "print largest frames" to save it as a pdf to desktop. This seems to sometimes cause compatability issues with pdf file when i open it on different computer and operating systems.

I haven't been able to find a option to make all pdf files open in preview rather than web browser. Was wondering if anyone had any insight into this issue.
Well, I don't know how to disable Safari's "vew pdf in browser" capabilities, but if you option click on any link (including links to PDF files), it will force-download the linked file (which will open in Preview).
 

MisterMe

macrumors G4
Jul 17, 2002
10,650
28
USA
raiempire said:
Before I installed Tiger OS, PDF files would open up preview. This allowed me to easily save the document to the desktop.

After installing Tiger OS, PDF files are opening up in safari browser making it more difficult to save. I need to hit "print largest frames" to save it as a pdf to desktop. This seems to sometimes cause compatability issues with pdf file when i open it on different computer and operating systems.

I haven't been able to find a option to make all pdf files open in preview rather than web browser. Was wondering if anyone had any insight into this issue.
The QuickTime plug-in opens PDFs in your browser if you set it up to do so. You can also open PDFs using the Acrobat plug-in. In any event, File > Save As ... saves your inline PDF to whereever you want.
 

ITASOR

macrumors 601
Mar 20, 2005
4,400
3
Yeah, I believe by doing Print-->PDF you're essentially converting a PDF to PDF, which could make it lookse quality or formatting I've heard. Just view the PDF in safari, and go to File-->Save As. This works great for me.
 

arf

macrumors member
Mar 2, 2004
55
0
UK
Solution?

A quick search on google came up with this:

Quit Safari, open up a terminal (Applications > Utilities) and type the following:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

to disable the pdf viewer and

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

to re-enable.
 

WildCowboy

Administrator/Editor
Staff member
Jan 20, 2005
16,783
1,065
A right click once the PDF is loaded brings up the contextual menu that lets you open in Preview. It's an extra step, but it works fine.
 

wordmunger

macrumors 603
Sep 3, 2003
5,125
2
North Carolina
arf said:
This works!
Dang! Doesn't work for me, using Safari in Panther. It drives me crazy when PDFs open up in Safari. It takes forever, and then you're using the Acrobat engine instead of Preview. I'd much prefer to view all PDFs in preview -- it's a much faster, much more elegant way to read them. I try to remember to crtl-click on them to open in Preview, but half the time I forget and have to sit there twiddling my fingers while the Acrobat plugin loads.

Anyone know how to disable this function in Panther?
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,641
12
Grand Rapids, MI, USA
wordmunger said:
Dang! Doesn't work for me, using Safari in Panther. It drives me crazy when PDFs open up in Safari. It takes forever, and then you're using the Acrobat engine instead of Preview. I'd much prefer to view all PDFs in preview -- it's a much faster, much more elegant way to read them. I try to remember to crtl-click on them to open in Preview, but half the time I forget and have to sit there twiddling my fingers while the Acrobat plugin loads.

Anyone know how to disable this function in Panther?
If you're getting PDFs displayed inline in Panther, are you using a plug-in, either one provided by Adobe, probably, or the one by Schubert-It, or are you using Quicktime 7? The plug-in should be a file in either ~/library/internet plug-ins/ or /library/internet plug-ins/ and you should be able to disable viewing inline by deleting it.

Also, FWIW, in Tiger, with Quicktime 7, you can do the following to turn off PDF display in Safari without using the terminal:

Open System Preferences -> Quicktime Preferences Pane -> Advanced -> MIME Settings

And then in this window, expand Images and deselect PDF. :)
 

amin

macrumors 6502a
Aug 17, 2003
977
9
Boston, MA
arf said:
A quick search on google came up with this:

Quit Safari, open up a terminal (Applications > Utilities) and type the following:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

to disable the pdf viewer and

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

to re-enable.
Awesome, thank you! I was looking for this as well.
 

wordmunger

macrumors 603
Sep 3, 2003
5,125
2
North Carolina
mkrishnan said:
If you're getting PDFs displayed inline in Panther, are you using a plug-in, either one provided by Adobe, probably, or the one by Schubert-It, or are you using Quicktime 7? The plug-in should be a file in either ~/library/internet plug-ins/ or /library/internet plug-ins/ and you should be able to disable viewing inline by deleting it.

Okay, that did it! Thanks!
 

Spectrum

macrumors 65816
Mar 23, 2005
1,385
749
Never quite sure
I'd just like to say...

This tip ROCKS!

downloading pdf's into Safari was my biggest peeve with Safari2.0 and Tiger - now it's fixed!

Thanks arf. We should make this sticky!

arf said:
A quick search on google came up with this:

Quit Safari, open up a terminal (Applications > Utilities) and type the following:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

to disable the pdf viewer and

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

to re-enable.
 

BornAgainMac

macrumors 603
Feb 4, 2004
6,373
3,242
Florida Resident
arf said:
A quick search on google came up with this:

Quit Safari, open up a terminal (Applications > Utilities) and type the following:

defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

to disable the pdf viewer and

defaults write com.apple.Safari WebKitOmitPDFSupport -bool NO

to re-enable.
Too bad it isn't a preference setting in Safari. Or even a way to specify which app you want to use to view your PDF files within Safari. Perhaps Safari 3.0 in 10.5. One of 200 new features coming in 2007 in OSX.