Safari and PDFs, frustration.

Discussion in 'Mac Apps and Mac App Store' started by Pressure, Mar 2, 2008.

  1. Pressure macrumors 68040

    Pressure

    Joined:
    May 30, 2006
    Location:
    Denmark
    #1
    Whenever I click on a PDF link in the Safari browser it tries to open it within the browser, which usually ends with the application crashing.

    I cannot seem to find anything in preferences that enables me to just have Safari download the PDF instead of trying to open it. An option that is available in Firefox but I much prefer Safari.

    Anyone know of a solution to my problems? :)
     
  2. lancestraz macrumors 6502a

    lancestraz

    Joined:
    Nov 27, 2005
    Location:
    RI
    #2
    There is a hidden preference that you can enable using Terminal to force Safari to download PDFs.
    I don't know what it is, though. Google it.
    Or you can "option" click on the link to the PDF to download it.
    Or right click the link to the PDF and select "Download linked file".
     
  3. Virgil-TB2 macrumors 65816

    Virgil-TB2

    Joined:
    Aug 3, 2007
    #3
    You could right-click on the link that leads to the PDF and select "save" or "download" or whatever it is.

    But seriously, if your Safari is crashing on that many PDF's there is something wrong with your installation of Safari. Are all the PDF's the same type or on the same network?
     
  4. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #4
    Hi!

    I don't know if there is an option for this in Safari. But OnyX will do the job. Download it here.

    In OnyX, go to Parameters
    Click the Safari tab and
    uncheck Automatically open .pdf files in Safari

    Hope this was helpful.

    /Rupert
     
  5. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #5
    If you do this, will the PDF download or open automatically in Preview?
     
  6. mackindergarten macrumors 6502

    Joined:
    Feb 21, 2008
    #6
    Yes!

    In case you have Acrobat Reader installed, you have to go to it's Preferences and under Internet disable the option Display PDF in browser using ...

    In Safari make sure, you have the option Open "safe" files after downloading enabled.

    That should do it.


    /Rupert
     
  7. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #7
    I'll give that a try, thanks. I'd been using the Acrobat Reader plugin out of habit, but decided recently to disable it because it's so slow to load, then became disenchanted with the way Safari handles PDFs in-line, with no obvious means of saving them locally.

    Nice web site, btw.
     
  8. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #8

    Generally it is advised to not have this option checked as it has been the source of potential security risks.

    Acrobat reader is very slow, I like the safari with its pdf browser as it is fast and if I want to save it I just press cmd+l then alt+enter.
     
  9. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #9
    As I say, no obvious way. ;)

    You can also use Save As in the File menu, or control-click, but this isn't as clear as having a save button on the page, and sometimes Save As can't find the right frame in a framed page and you end up saving a useless html file. Non-technical people have a real problem with the way this works, and I don't like it much either.
     

Share This Page