Safari and videos

Discussion in 'Mac OS X Lion (10.7)' started by leekaiwei, Jan 8, 2012.

  1. leekaiwei macrumors member

    leekaiwei

    Joined:
    Jul 23, 2011
    Location:
    U.K.
    #1
    When I try to watch Youtube videos, until I make the tab with the Youtube page on it active, the flash part of the page (basically the video) doesn't load.

    Also, videos from Dailymotion don't load properly. The video part of the page just jumps to the upper left hand of the page. Yet when I click on where the video was meant to be, the video still plays. It's kind of hard to describe. I can provide a screenshot if anyone needs it.
     
  2. 01jamcon macrumors 6502a

    01jamcon

    Joined:
    Jul 24, 2006
    Location:
    London
    #2
    That is the default behaviour of Safari, I'm not sure if you can manually change the setting. As for your dailymotion video problem, I'm not sure, try using a different browser such as Chrome to see if it displays the same problem there too.
     
  3. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #3
    1. Does this video problem occur with other browsers like Chrome/Firefox? Do you have the latest versions of Flash/Silverlight (if you use these instead of HTML5 versions of Youtube/etc)?

    2. Are you running any extensions in Safari?

    3. The Youtube videos not loading until tab is active is default behavior. Dailymotion issues may be related to an extension/plugin in Safari.
     
  4. leekaiwei thread starter macrumors member

    leekaiwei

    Joined:
    Jul 23, 2011
    Location:
    U.K.
    #4
    I tried Firefox and Dailymotion works fine. I only have AdBlock as an extension. Is the Youtube thing a design feature or just something that people never minded and so never changed?
     
  5. leekaiwei thread starter macrumors member

    leekaiwei

    Joined:
    Jul 23, 2011
    Location:
    U.K.

Share This Page