Safari and Youtube huge problem

Discussion in 'OS X Mountain Lion (10.8)' started by emir, Nov 4, 2012.

  1. emir macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #1
    Hi everybody;

    I honestly love using Safari and prefer to use it rather than Firefox, Chrome or Opera. However when in youtube there's a huge issue with it on Mountain Lion.

    This is the only issue i have with the entire operating system. I have a 2010 MBP 15" and i am running 10.8.2 with Safari 6.0.1

    Youtube player always crashed and had general problems, found out i was in youtube html 5 trial and got myself out of it thinking this will resolve it but no. Now it's better than html5 however player gives me issues. I don't know how to describe this since my native language isn't English but i'll give it a try.

    When a video starts play, like 10 seconds later video continues playing but the counter where you control, pause, skip just resets. It looks like video is not playing, seconds sit at 0:00 even though i am watching it and you cant pause or anything. 10-20 seconds later from that the video stops. It looks like it paused because it didn't load the rest but it does. There's just a spinning loading wheel in the middle of the video and i can't rewind, skip, pause play anything. Think it crashes.

    So i reload the page skip the 30 seconds i was able to watch, then 10 second after that second counter resets again this time to 0:30 (time which i skipped to in the beginning) then 10-20 seconds after that same thing happens again, video stops. I reload again and skip to let's say 0:53 hoping it won't happen again. This happens in almost all videos and i can't watch videos on Youtube the way i am supposed to.

    Yes my flash player is updated and the latest and i don't have this issue with any other flash player video site.

    I've done some search on the web and can't find any solutions, thanks a lot in advance.

    Cheers;
     
  2. emir, Nov 4, 2012
    Last edited: Nov 9, 2012

    emir thread starter macrumors 6502a

    emir

    Joined:
    Apr 5, 2008
    Location:
    Istanbul
    #2
    It appears i have found the solution for anyone who also has this problem or finds this thread from google or something in the future.

    This is not a browser nor os problem. This is problem from youtube's part and people think it's because if the ads that appear in the video. buffering crashes.

    to solve this on safari with mac. Click on Safari from the top menu, click on safari extensions. Then from the page that opens find "AdBlock" and install it.

    That's it.
     

Share This Page