safari appears in all desktops

Discussion in 'Mac OS X Lion (10.7)' started by Fazzy, Nov 21, 2011.

  1. Fazzy macrumors 6502

    Joined:
    Oct 12, 2011
    Location:
    check the tracking device
    #1
    when i have safari open and swipe to the next space, safari appears in the new space. Also when i activate mission control, safari won't show up in any of the spaces. this doesn't happen with any of my other apps.
     
  2. jameslmoser macrumors 6502

    Joined:
    Sep 18, 2011
    Location:
    Las Vegas, NV
    #2
    I think you might have Safari assigned to all Workspaces. If you have Lion, Right click (or Ctrl click) on the Safari Dock icon, Choose "Options" and under "Assign To" choose "None". If you have Snow Leopard, check System Preferences => Expose & Spaces, Under Spaces, check Application Assignment.
     
  3. Fazzy thread starter macrumors 6502

    Joined:
    Oct 12, 2011
    Location:
    check the tracking device

Share This Page