Safari appending WWW. to URL's...just started

Discussion in 'iPad' started by Eric-PTEK, May 23, 2010.

  1. Eric-PTEK macrumors 6502

    Joined:
    Mar 3, 2009
    #1
    Well this is pissing me off....this of course happens when I sit down to show someone something.

    We do web and app development. While testing we use xxxxxx.ourdomain.net.

    Like our CRM software we use internally is hosted at crm.ourdomain.net.

    A few customer websites are the same while in dev. For some reason today, and just today, the iPad started to append www. to whatever I type in.

    So if I type in jans.ourdomain.net I get www.jans.ourdomain.net

    I can still goto a URL that Safari has kept like our CRM page but nothing new. I can get to them anywhere else so its not a DNS issue or anything like that.

    I could find no option to turn this off anywhere.

    Anyone?
     
  2. antiprotest macrumors 65816

    antiprotest

    Joined:
    Apr 19, 2010
  3. santaliqueur macrumors 6502a

    Joined:
    Aug 7, 2007
    #3
    Happens to me, not sure why I needed to leave off www, but it was annoying.
     
  4. InsiderApps macrumors member

    Joined:
    Mar 18, 2010
  5. ThirteenXIII macrumors 6502a

    Joined:
    Mar 8, 2008
    #5
    id double check on the server side of the website.
    because the Safari app for the mobile device maybe telling the server to try and load a non-mobile version of it so it thinks if it sends it to a WWW. itll load the intended page.


    all the sites ive been working on that are subdomains without www load fine without the www being auto filled or whats happening in your case.
     
  6. paulisme macrumors 6502

    Joined:
    Dec 15, 2008
    Location:
    Charleston, SC
    #6
    I'm pretty sure Safari only adds "www" to an address when the address as entered can't be found, which makes me think the problem lies with your server.
     
  7. briankwest77 macrumors member

    Joined:
    Feb 26, 2010
    #7
    sounds Like your dns servers are doing some sort of hijacking and redirecting.

    /b
     
  8. Eric-PTEK thread starter macrumors 6502

    Joined:
    Mar 3, 2009
    #8
    Not on the server side. I can get there with either my wife's or my iPhone no problem. We don't have a mobile version nor do we do any redirection for browser types.

    The address not found issue would be a DNS problem which is AT&T but side by side the iPad will not find it connected to 3g while the iPhone will. This is via 3G.

    I just tried it right now, going to the site on my iPhone and on the iPad, the pad does the www, the phone does not.
     
  9. billyzenme macrumors member

    Joined:
    Dec 21, 2009
    #9
    the problem isn't coming from the iPad, it's your server.
     
  10. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #10
    what was suggested was, mobile devices generally try to check if its a mobile version or not as some are m.website.com etc, not stating you had a mobile version but looks for a compatible mobile version of the site to load otherwise it will pull the main non-mobile version.

    so thus its triggering the www.

    try with http:// see if it resolves to your page or not.
    id restart the dns on the server, as said before its not a safari issue as it seems.
     
  11. Eric-PTEK thread starter macrumors 6502

    Joined:
    Mar 3, 2009
    #11
    I'm using 3G, so its not my DNS, it is AT&T's.

    Second all the sites have identical settings, completely in IIS 7.5.

    Third we do NOT do mobile redirection and we do no browser check.

    Everyone says it is the server but no one addresses the fact that it works fine on the iPhone, but not on the iPad.
     
  12. RobBookPro macrumors regular

    Joined:
    Jun 17, 2009
  13. InsiderApps macrumors member

    Joined:
    Mar 18, 2010
    #13
    Have you tried adding "http://"? I can't see why this won't work.
     
  14. Eric-PTEK thread starter macrumors 6502

    Joined:
    Mar 3, 2009
    #14
    I have not but will.
     
  15. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #15
    Sounds like it's AT&T's fault, but that shouldn't surprise anyone.
     

Share This Page