Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

rogertb

macrumors member
Original poster
Jul 17, 2006
41
3
Bexhill UK
afill.jpg
Hi chaps - really annoying, I have moved house, deleted old card and created a new contact card for "My Card" trashed caches and dbs everywhere I can think of but from somewhere Safari is still finding an old address ... even more odd sometimes it mixes and matches, when using autofill on this page it has entered my OLD address in line 1 and my new address in line 4 & 5 ... go figure !

I have searched the Mac ... deleted a couple of other old accounts (ones I've used for 'testing' and things) - I cannot find reference to "Twynham" (old address) anywhere on my Mac ... anyone any thoughts please ?
 
  • Like
Reactions: xoAnna

rogertb

macrumors member
Original poster
Jul 17, 2006
41
3
Bexhill UK
Yes, that's what I see ... believe me I'm not an idiot - I have done, I think, everything correctly as I said in my original post "deleted old card and created a new contact card for "My Card""

Safari is finding an old address from somewhere ...........
 

MC6800

macrumors 6502
Jun 29, 2016
369
126
I believe he's asking what you see when you click on the contacts Edit button there (to check if it's using the card you expect).
 
  • Like
Reactions: Weaselboy

rogertb

macrumors member
Original poster
Jul 17, 2006
41
3
Bexhill UK
Thank you
af.jpg

[doublepost=1494832021][/doublepost]here's a perfect example of the blank form with the autofill drop-down and what Safari autofills, the grab in my previous reply shows "MY" card information
 

Attachments

  • before and after.jpg
    660.9 KB · Views: 777

Weaselboy

Moderator
Staff member
Jan 23, 2005
34,125
15,582
California
Hmm... sorry. I'm at a loss. o_O

Changing that card like you did should do it and you have it setup correctly.
 

MC6800

macrumors 6502
Jun 29, 2016
369
126
What happens if you select "Customize..." (as seen in your "before" image). When I do that it gives me a dialog with a pop-up choice for each of phone, email, and address. Maybe yours still has the old address chosen?
 

rogertb

macrumors member
Original poster
Jul 17, 2006
41
3
Bexhill UK
Good thinking MC ... but it just comes up with the correct NEW address ... I can always find a way round the problem (except for the day I didn't notice and a £20 value parcel was delivered to my old address) but I'd really like to know where Safari is looking !
 

MC6800

macrumors 6502
Jun 29, 2016
369
126
That's really crazy. I noticed that after autofill fills in fields you can click on a field and then select the autofill icon pulldown and it says where the contents came from, such as "home". You could see if your address fields are somehow different.
 

rogertb

macrumors member
Original poster
Jul 17, 2006
41
3
Bexhill UK
It is very strange ... I have searched (for "Twynham" - the old address) on my Mac using spotlight, I have searched 'contacts' as well, I have cleared Safari's caches etc etc ... I cannot think of anywhere else the old address might be !
 

JonD25

macrumors 6502
Feb 9, 2006
423
9
Did you ever figure this out? I noticed this happening myself recently. I just moved, changed my address in my contact form. But when I tell it to autofill my home address in Safari, it's filling in my old address still. Really annoying.
 

rogertb

macrumors member
Original poster
Jul 17, 2006
41
3
Bexhill UK
Did you ever figure this out? I noticed this happening myself recently. I just moved, changed my address in my contact form. But when I tell it to autofill my home address in Safari, it's filling in my old address still. Really annoying.
Hi Jon ... I eventually got through to Apple 'chat' support in the States and after several people tried, without success, I was passed onto a supervisor who showed me where there were some data 'caches' that I deleted - I'm really sorry I didn't spot where the folder was.
 

juliandfortune

macrumors newbie
Jul 22, 2019
1
0
In case anyone else is still having this issue, I was able to resolve it by:
1. Signing out of iCloud
2. Removing all files with "com.apple.safari" in `~/Library/Caches/`
3. Removing the folder `~/Library/Safari/`
4. Restarting my computer
5. Signing back into iCloud
6. Restarting my computer again

Hope this is helpful.
 

Kalmt

macrumors newbie
Oct 1, 2019
1
0
Just did this exactly as written. I believe it may have worked in your case, however in mine it rendered autofill to not work at all and I lost 7 years of browsing history.

Forums have sooo much mis-information out there folks. My suggestion is to just call apple's tech support with any issues. They actually have pretty decent help these days.

In case anyone else is still having this issue, I was able to resolve it by:
1. Signing out of iCloud
2. Removing all files with "com.apple.safari" in `~/Library/Caches/`
3. Removing the folder `~/Library/Safari/`
4. Restarting my computer
5. Signing back into iCloud
6. Restarting my computer again

Hope this is helpful.
 

louvest

macrumors newbie
Sep 10, 2009
2
0
I was having the same problem. I edited my contact card and removed my old card but Safari kept using my old address. I even went into the Contacts app to be sure my old address was not in there. Turns out you have to close out of Safari and reopen after editing the card. This seems like good programming would not require you to do that but there it is. At least that worked in my case.
 

SRA2023

macrumors newbie
Jun 14, 2023
1
0
I know this is an old thread, but for me, I figured out that Safari was autofilling using my 1Password plug-in contact card data. So no matter what I did to my Apple/iCloud contact card, 1Password, or and other similar 3rd party app, will always override your Apple contact info.
 

MacLayman

macrumors newbie
Jun 16, 2023
2
3
This drove me nuts and I seem to have found the problem in my situation. My contact card was up to date, and I tried toggling Autofill settings on and off as described elsewhere. The problem persisted. Here's what fixed it:

1. In Finder, open the Library file (https://www.macrumors.com/how-to/reveal-library-folder-in-macos/)

2. Open the Safari folder, and move the "Form Values" file to the trash.

3. Empty the trash.

You may need to restart Safari or the Mac, I don't recall. But my old address is now gone!

(4. You may also need to move the following to the Trash, although when I initially tried this it didn't work. It was only after I deleted "Form Values". Anyway, also delete these from the Safari folder: AutoFillCorrections.db, AutoFillCorrections.db-shm, AutoFillCorrections.db-wal. MacOS will re-create clean versions for you.)

This old post talks about the Form Values file. I'm guessing it's something some of us have been carrying around from old versions of Mac OS.

 
Last edited:
  • Like
Reactions: IVIarth and moritzz

MacLayman

macrumors newbie
Jun 16, 2023
2
3
Hi Jon ... I eventually got through to Apple 'chat' support in the States and after several people tried, without success, I was passed onto a supervisor who showed me where there were some data 'caches' that I deleted - I'm really sorry I didn't spot where the folder was.
For me it was Library/Safari/Form Values
 
  • Like
Reactions: ColinBlake

masochist

macrumors newbie
Apr 28, 2017
25
35
Just for anyone else finding this page in the future, I'm making a note here: great success. Removing the Form Values file and the AutoFillCorrections files fixed this for me.
 

ColinBlake

macrumors newbie
Jul 11, 2014
1
0
Just for anyone else finding this page in the future, I'm making a note here: great success. Removing the Form Values file and the AutoFillCorrections files fixed this for me.
For me it was Library/Safari/Form Values
Thank you!! This has been driving me crazy for 16 months. Removing the ~/Library/Safari/Form Values folder did the trick.
 
Last edited:

EmmaLou

macrumors newbie
Oct 30, 2023
1
0
This drove me nuts and I seem to have found the problem in my situation. My contact card was up to date, and I tried toggling Autofill settings on and off as described elsewhere. The problem persisted. Here's what fixed it:

1. In Finder, open the Library file (https://www.macrumors.com/how-to/reveal-library-folder-in-macos/)

2. Open the Safari folder, and move the "Form Values" file to the trash.

3. Empty the trash.

You may need to restart Safari or the Mac, I don't recall. But my old address is now gone!

(4. You may also need to move the following to the Trash, although when I initially tried this it didn't work. It was only after I deleted "Form Values". Anyway, also delete these from the Safari folder: AutoFillCorrections.db, AutoFillCorrections.db-shm, AutoFillCorrections.db-wal. MacOS will re-create clean versions for you.)

This old post talks about the Form Values file. I'm guessing it's something some of us have been carrying around from old versions of Mac OS.

This is the answer!!!

I have this issue every time I change my address.
  • Often switching "My Card" to a different card and then switching back fixes it.
  • Sometimes deleting My Card and re-adding works but this time it didn't.
  • I just got off the phone with Apple and 78 minutes and 3 supervisors later, this was the solution. Go open a Finder window > select the Go tab, push the option key on the keyboard, and then select Library. Scroll down to the Safari folder. Within the Safari folder, delete the "Form Values" folder.
So for anyone else finding this in the future, if the first steps don't work, try deleting the Form Values file in the Safari Library folder.
 

moritzz

macrumors newbie
Jul 14, 2009
6
2
Zürich
This drove me nuts and I seem to have found the problem in my situation. My contact card was up to date, and I tried toggling Autofill settings on and off as described elsewhere. The problem persisted. Here's what fixed it:

1. In Finder, open the Library file (https://www.macrumors.com/how-to/reveal-library-folder-in-macos/)

2. Open the Safari folder, and move the "Form Values" file to the trash.

3. Empty the trash.

You may need to restart Safari or the Mac, I don't recall. But my old address is now gone!

(4. You may also need to move the following to the Trash, although when I initially tried this it didn't work. It was only after I deleted "Form Values". Anyway, also delete these from the Safari folder: AutoFillCorrections.db, AutoFillCorrections.db-shm, AutoFillCorrections.db-wal. MacOS will re-create clean versions for you.)

This old post talks about the Form Values file. I'm guessing it's something some of us have been carrying around from old versions of Mac OS.

Hurray, @MacLayan, you solved the mystery! This finally solved the issue for me too. Thanks a lot for sharing, M.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.