Safari automatically sends Passwords

McMario

macrumors newbie
Original poster
Aug 20, 2011
7
1
Hi,

came across a (maybe) dumb issue:

before 10.14.4:
- website-form with login, password & options (like, "remember me for 14 days" etc.)
- safari presents you with the suitable, keychain-remembered password
- you select it
- THEN you check any boxes below (see line 1)
- THEN you click SEND, LOGIN or whatever

now:
- dto
- but: as soon as you select the stored login, safari automatically sends it already, like hitting the enter button for you...
- that way, you have to click any options BEFORE you select the password...

can someone confirm this behaviour?

cheers
 

tungsteno

macrumors newbie
Apr 6, 2019
4
0
yes.. and if you have to use captcha IT IS IMPOSSIBLE TO STOP and you have to do it again...
No options to remove it for this bug...
ALL PASSWORD now where it is used captcha CANNOT be reached...
 

Ritsuka

macrumors 65816
Sep 3, 2006
1,080
549
There are already some threads with how to disable this behaviour on this forum.
 

tungsteno

macrumors newbie
Apr 6, 2019
4
0
There are already some threads with how to disable this behaviour on this forum.
Thanks for the link... I mean I did search and found just threads like this one and still have no resolved, and you just say it has been resolved without quoting or giving a link... it seems to you normal? would not be easy not to write if the information does not help in any case?
 
Last edited:

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,840
1,163
Including above, seen the behavior as hit miss (no touch bar on my MBP). Some sites get into the loop, some will wait for captcha to be done. Guessing something in how some sites are coded.

Just a guess, as has not been a major issue for me on latest of everything.
 

tungsteno

macrumors newbie
Apr 6, 2019
4
0
The only way to use Captcha with this new ******** of Apple, is to do Captcha before to give the password autofill.
Or maybe another solution is to switch to.. Firefox
 

McMario

macrumors newbie
Original poster
Aug 20, 2011
7
1
The only way to use Captcha with this new ******** of Apple, is to do Captcha before to give the password autofill.
Or maybe another solution is to switch to.. Firefox
just switched to FF a few days ago. sad.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.