Safari being weird?

Discussion in 'Mac Apps and Mac App Store' started by rye9, Oct 23, 2007.

  1. rye9 macrumors 65816

    rye9

    Joined:
    Sep 20, 2005
    Location:
    New York (not NYC)
    #1
    Today, all of a sudden, Safari has not been functioning as it used to. Any site which my username and/or screen name was automatically remembered, generally by the "remember me?" feature in most log in areas, is no longer working. These forums, MySpace, etc... every time I visit, regardless of whether Safari is closed or not, just wipes itself clean and I have to re-enter everything. Why could this be and why all of a sudden? Thanks :)
     
  2. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #2
    Do you have "Private Browsing" enabled? This will make it so that Safari won't keep any cookies from sites you visit, which would create that behavior.
     
  3. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #3
    Check Safari --> Preferences --> Security. Did your "Accept cookies" setting get turned off by any chance?
     
  4. rye9 thread starter macrumors 65816

    rye9

    Joined:
    Sep 20, 2005
    Location:
    New York (not NYC)
    #4
    I use Private Browsing every time and have for years. And my cookies are enabled.
     
  5. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #5
    Hmm...I thought Private Browsing automatically deleted all cookies at the end of your browser session. :confused:
     
  6. MacNut macrumors Core

    MacNut

    Joined:
    Jan 4, 2002
    Location:
    CT
    #6
    I think it only deletes the ones during private browsing, not the others.
     

Share This Page