Safari blank pages

Discussion in 'Mac Basics and Help' started by Hai1242, Dec 12, 2010.

  1. Hai1242, Dec 12, 2010
    Last edited: Dec 12, 2010

    Hai1242 macrumors member

    Joined:
    Jul 21, 2010
    #1
    Hello,

    When I open up safari, every webpage works. But, randomly www.--------.net loads up blank. Reloading does not help either. Every other page works still. The only way I can fix it is to force quit safari and then reload the program...

    I have tried deleting the com.apple.safari.plist and the only extension I use is LastPass.

    Does anyone have any ideas on what is causing this? Thank you.
     
  2. LPZ, Dec 12, 2010
    Last edited: Dec 12, 2010

    LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    A very clever effort to bring visitors to the site. But we're not so easily tricked. :)

    I loaded the page a dozen times, emptying the cache after each visit. It loaded perfectly each time. I never read any of the content. ;)

    Has this error ever occurred with extensions disabled in Safari?
     
  3. Hai1242 thread starter macrumors member

    Joined:
    Jul 21, 2010
    #3
    I am serious, i blanked out the url so you won't think it's an advertisement. Yes I have tried to turn off the 1 extension I have and it still loads blank from time to time.
     
  4. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    I was joking. Put the URL back so folks can test it.

    Why do you need to force quit Safari? Does it freeze up when the empty page loads? Also, anything indicated in the Safari Activity window when the error happens?
     
  5. Hai1242 thread starter macrumors member

    Joined:
    Jul 21, 2010
    #5
    Well I know for a fact it's not the webpage that is at fault, so that doesn't matter. It's something with my safari... and that specific website on my safari. It loads up blank, no pinwheel or anything. It does not stall or anything, I can type in a different website like cnn.com and it goes straight to it. It loads the 17 items on the webpage in question like normal, but just ends up being a blank page. The "View Source" shows up like a normal website too.

    After I force quit and reload safari that page it works magically again. I'm just going to try to find a way to reinstall safari maybe? The .plist deleting didn't work, so I was just fishing for ideas :). Thanks for any help I can get.
     
  6. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    When I load http://slickdeals.net/ I get 260 item listed in the Safari Activity window. Why do you say 17 items? Have you tried deleting all cookies from the site? I assume you've emptied the cache. You might try Reset Safari in the Safari menu.
     

Share This Page