Safari: Can I Disable "Use Strong Password" prompt?

Discussion in 'macOS Mojave (10.14)' started by Jodeo, Apr 26, 2019.

  1. Jodeo macrumors regular

    Jodeo

    Joined:
    Sep 12, 2003
    Location:
    Middle Tennessee
    #1
    Whenever I create an account I'm greeted with the ever-annoying "Safari created a strong password for this website" prompt.

    I prefer NOT to use Safari's suggestions and would rather never see this prompt again.

    How can it be disabled? I checked Safari preferences and System Preferences, but no luck.



    [​IMG]


    Thank you.
     
  2. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #2
    Disable autofill.
     
  3. Jodeo thread starter macrumors regular

    Jodeo

    Joined:
    Sep 12, 2003
    Location:
    Middle Tennessee
    #3
    So I can either have auto-fill populate fields for me AND have this prompt, or have no auto-fill at all?
     
  4. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #4
    AFAIK, that is (unfortunately) correct.
     
  5. mj_ macrumors 6502

    mj_

    Joined:
    May 18, 2017
    Location:
    Austin, TX
    #5
    That prompt is driving me nuts, too. It's infuriating how annoying macOS has become.
     
  6. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #6
    Do you really create new accounts that often for it to be such an infuriating issue?
     
  7. Jodeo thread starter macrumors regular

    Jodeo

    Joined:
    Sep 12, 2003
    Location:
    Middle Tennessee
    #7
    Yes.
     
  8. mj_ macrumors 6502

    mj_

    Joined:
    May 18, 2017
    Location:
    Austin, TX
    #8
    If only it were so simple ;) The issue is that Safari seems to consider the login window on many websites a registration form and prompts me to use a safe password to register when really all I want is to to log in. What's infuriating is the fact that this dialog/prompt is modal and I have to first manually click it away before I can proceed to log in instead.
     
  9. question fear macrumors 68020

    question fear

    Joined:
    Apr 10, 2003
    Location:
    The "Garden" state
    #9
    Yup. I have the same issue when I try to log remotely into my office-it thinks the security code/password setup is a prompt to set up a new password and offers to create a strong one for me every time.

    It's not a huge deal, but I would love a "not for this website" option...that's all it would take!
     
  10. posguy99 macrumors 6502a

    Joined:
    Nov 3, 2004
    #10
    Turn off iCloud Keychain.
     
  11. mogtron macrumors newbie

    mogtron

    Joined:
    May 31, 2019
    Location:
    Brisbane, Australia
    #11
    I googled this problem and ended up here. Very dismayed to hear there is no fix.
     
  12. a2jack macrumors regular

    a2jack

    Joined:
    Feb 5, 2013
    #12
    Dump Safari and go to Firefox. That should fix it. Yes ?
     
  13. willmtaylor macrumors G3

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #13
    No. It avoids it. The two are not the same.
     

Share This Page

12 April 26, 2019