Safari can't connect to certain websites

Discussion in 'Mac Basics and Help' started by pbook4g5, May 11, 2008.

  1. pbook4g5 macrumors newbie

    Joined:
    Aug 11, 2005
    #1
    Hello all,
    I have three computers on my home network; A dual 1.8 G5 with Leopard, a Macbook Pro with Leopard, and a Windows XP Box.

    My problem with Safari started about 3 months ago, when I tried accessing a website via my g5. Safari said it could not connect to the server. I assumed the site was down. However, I hopped on my MBP and the site worked fine. In fact, I found a lot of sites that my G5 didn't want to access that my MBP could, on the same network. I have flushed my DNS cache, reset safari, cleared safari's cache, reset my router, cable modem, checked the DNS servers. Everything seems identical between the MBP and the g5. Anyone have any ideas what could be causing this issue with the g5 and possible fixes? I have searched for the past two days and I can't seem to figure it out. Thanks,

    -T

    EDIT:The problem happens in both Safari and Firefox
     
  2. matt90 macrumors member

    Joined:
    Feb 18, 2008
    Location:
    Los Alamos, New Mexico (Atomic City)
    #2
    Try downloading a freeware Internet browser and accessing the sites with that. If you still can't connect, then I can't help you.
     
  3. dukeman macrumors member

    Joined:
    Feb 5, 2007
    #3
    maybe a host file issue?
    "/private/etc/hosts file. For more information on how to use the hosts file, open Terminal and type: man hosts "
     
  4. juniperlater macrumors newbie

    Joined:
    Oct 10, 2007
    #4
    I am having the same problem.

    Here is what I have done:

    I have disabled ipv6.
    I have flushed the DNS cache.
    I have reinstalled Leopard (works fine in Tiger).
    I have updated to 10.5.4.
    I have reset Safari.

    I still cannot connect to:

    classicclubgolf.com
    getrichslowly.org

    If I connect through a proxy, they work fine.

    Any ideas?
     
  5. vasanth4u macrumors member

    vasanth4u

    Joined:
    Jun 29, 2008
    #5
    Hi this is VASANTH here
    >>>These are the steps that will rsolve your issue:
    >>Download Mozilla Firefox from apple downloads page , and it will work there
    >>Try in different user account and check weather it is working there .
    >>If not reinstall safari.
    >>If it works there remove the plist in your user library
    >>Even if this is not working
    >>Archive and install with preserving user and network settings
     
  6. ZballZ macrumors regular

    Joined:
    Nov 11, 2006
    #6
    Safari SUCKS! :mad:

    I am on Tiger, and actually prefer prefer safari over firegox (like the look better :)) But there are too many issues with it; to many sites wont work, it hangs at certain things all the time - even Gmail seems to hang and cause problems in safari sometimes ...

    The thing is, 96% of all websites are accessed from internet explorer from a PC. So, the webmasters optimize their sites for this standard. Of course, they are aware of mac-users (sometimes!!) and optimize for FireFox as well. Why they choose firegox, I dont now, But normally all sites are working fine from Firefox. Like it or not - get firefox (its free) and it will solve most of your problems...
     
  7. juniperlater macrumors newbie

    Joined:
    Oct 10, 2007
    #7
    Okay,

    1. Firefox - nope.
    2. Other User - nope.
    3. Remove plist - nope.
    4. Reinstall - Didn't work.
     
  8. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Both sites come up instantly on my Safari 4.0. I'm guessing the sites were having some problems.
     
  9. juniperlater macrumors newbie

    Joined:
    Oct 10, 2007
    #9
    PeerGuardian

    PeerGuardian was the reason my browsers wouldn't connect. I hope this helps some folks out there.
     
  10. jdanilson macrumors newbie

    Joined:
    Feb 7, 2008
    Location:
    McLean, VA
    #10
    similar issue on g4 and firefox

    Like others, I'm having a similar issue. I've a powerbook g4 running 10.5.5 which cannot connect to a random set of sites although both Imacs on the same network can connect.

    Based on my investigation I think it's a dns issue which supposedly was solved with 10.3.x but which nevertheless seems to be the cause of my problem.

    Here's a good write up.
    http://hunter.pairsite.com/blogs/blog20080603.html

    Bottom line. I'm still struggling, but with the tcpdump details in this write up I should be able to get more insight tonight when I get back home on my house network with the offending G4.

    btw, a powerbook running 10.4 on my home network works just fine.
     
  11. J4m!s0n macrumors newbie

    Joined:
    Jan 4, 2010
    #11
    I've FINALLY Found the Solution!

    Hey to those who posted in this message and to those viewing this in the recently answered "bumped" messages...

    I have a 15" White Macbook with Leopard OS X Version 10.5.8
    Bought in July 2007
    2.16 GHz Intel Core 2 Duo Processor
    1.5 GB 667 MHz DDR2 SDRAM Memory

    111.47 Gb Harddrive
    104.66 Gb Used
    6.81 Gb Free ....... (I know I KNOW!! ..I'm working on getting all of my crap onto harddrives to get to that 15Gb plateau and higher. Only 2 problems: Too much stuff that needs to be accessed daily & portably, and no money for a large external HD or for a new Macbook).

    Anywhooo...I kept having the same problem with my computer:
    -Web pages would take SOOO LONG to load
    -Some would never even load
    -Facebook & Myspace basically crashed by computer with all of the incoming transmissions
    -Some pages did load, but not everything loaded
    -It's rare that all of the images come up on a page
    -YOUTUBE NEVER LOADS. EVER.

    Well I found the problem!

    For a very small monthly fee, I can guarantee

    No just kidding...you gotta update Java! go here it's straight outta Apple's factory, and it has been since April 29, 2008!!

    http://www.apple.com/downloads/macosx/apple/application_updates/javaformacosx105update1.html

    It's the 1.6.0_05 Java Update, and it fixed everything. I hope this helps you all too!!!
    :apple: J@m!s0n
     
  12. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #12
    From the "more info" link:

    This release is for 64-bit, Intel-based Macs only and cannot run on PowerPC-based or 32-bit Intel-based Macs.
     
  13. dustn macrumors newbie

    Joined:
    Dec 20, 2010
    #13
    For what it's worth, as soon as I disabled PeerBlock, everything worked fine.
     

Share This Page