Safari can't establish secure connection

Discussion in 'MacBook Air' started by Steelseries, Sep 28, 2013.

  1. Steelseries, Sep 28, 2013
    Last edited: Sep 28, 2013

    Steelseries macrumors member

    Aug 2, 2013
    I need help. Safari can't open some pages such as google. It says Safari can't open the page because safari can't establish a secure connection to the server Itunes and the Mac App Store don't work as well because they say they can't connect to the Internet. I can open certain pages such as apple website, wikipedia, facebook, a lot actually. But google doesn't work.

    I'm using OS 10.8.5, 2013 Macbook Air, i5/4gb/256 gb. also, Safari 6.0.5

    I can't connect to iTunes Store/ Mac App Store so I can't update my software.
  2. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    When did this start happening? Did you change some settings or install an adblocker or something maybe?
  3. badman89 macrumors regular

    Dec 24, 2011
    You first need to determine whether the problem is with your computer or with your router. Take your computer to your office / friend's house / somewhere else and see if the internet is working properly. If yes, then the problem is with your router.

    My recommendation: take your computer to the Apple store. If you have the same connectivity problems with the store's wifi, then it's your computer's fault and they will fix it for you. Otherwise it's likely to be your router's fault, in which case you can pick up a new router from the Apple store and your problem should be solved.
  4. Steelseries thread starter macrumors member

    Aug 2, 2013
    Thank you for the replies. I don't think the problem is the router, because Google Chrome works fine for me, my other laptop (windows) works fine with wifi. Also, I reinstalled OS X on my Mac but it still happens. All Apple apps can't seem to connect to the Internet. (iMessage, Facetime, Game Center, iTunes, Mac Apps Store, Mail. Safari still can't access google. I thought this was an outage or something but it has been two days since this happened.

    I found some other guys who have the same problem here:

    I tried everything but nothing happened. I haven't gone to the Apple Store yet. It's so far from our home. Also haven't tried to connect to someone else's wifi.

    But I think it's a OS X problem. 10.8.5 seems unusable for me.
  5. Mrbobb macrumors 601

    Aug 27, 2012
    Well sure sounds like Safari as you describe it but I haven't the faintest idea what it could be.
  6. DisplacedMic macrumors 65816

    May 1, 2009
    this would be a good thing to mention in your OP, fyi because it really reads like an internet connection problem with some pages cached.

    chrome works fine - as in you can load NEW pages?
    if so then you still need to rule out the wifi router.

    Do you have the ethernet adapter?
    unplug and turn everything off. let it sit off for a few minutes, then connect your MBA to the modem directly. even if you don't have a way to hardwire in a global reboot of the router and modem wouldn't hurt.

    You could try creating a new network location. For some reason google says people have reported this fixing problems similar to yours...

    apple logo > system preferences > network > location pulldown > edit locations

    click +
    name it something

    try again. (definitely restart safari but i would reboot the entire's an air, that only takes 30 seconds anyway:p)

    if neither of those work then you could going into safari and uninstalling extensions. although i am concerned that you are saying other Apple apps aren't working either...

    barring that i'm not sure. it's apple store time. i know you said they're far away but they also have phone and chat support that is pretty good.

    good luck
  7. Steelseries thread starter macrumors member

    Aug 2, 2013
    Thank you for the reply. I called my ISP about this today. They said there were a lot of reports about this recently. They were also unsure about what really was the problem. Well,finally, after 2 and a half days, I can connect to the App Store again. Everything seems fine now. I think this is selective outage by Apple or the ISP.
  8. DisplacedMic macrumors 65816

    May 1, 2009
  9. lie2me macrumors member

    Apr 23, 2010
    I just fixed the same problem.

    I have a Airport Extreme connected to a DLINK router that is connected to a cable modem.

    All the desktop macs did not have this problem. It was only my macbook air that was having this problem that was connecting through to the airport extreme.

    I had changed some settings on the DLINK router (open a couple VPN ports) and rebooted it. After that I was getting the Can't Establish a Secure Link error message for reasons why I could not open certain web sites. I shut off and powered back up the Airport Express thing that might help but it did not.
    I looked at my proxy settings and everything seemed ok. I checked my keychain using the keychain access application by verify and repair. I cleared all cookies. I reset safari. All to no avail.

    Finally I bit the bullet and powered down the whole LAN, including the airport, the Dlink router, and the cable modem. I then powered them back up starting with the cable modem, the DLINK router, and then the airport router.
    That is what solved my problem. I am now able to surf the internet without these messages.

    By the way, the secure link issue most likely will effect other applications such as Dropbox, Apple Mail, etc.
  10. nickbw macrumors newbie

    Mar 11, 2014
    None of this worked for me but I have fixed my problem

    Ok so I have a mid 2010 Macbook Pro 13" Aluminum laptop 7.1 with 10.10.3 and Safari v 8.0.5

    I started getting error messages every time I wished to connect in Safari to SSL http:// web addresses.

    I found this particularly frustrating since I recently gave a similar MackBook Pro 13" Aluminum laptop to my daughter, configured similarly but importing her accounts and software from an iMac with Lion OS X. The latter setup had no such problem with SSL http://.

    So having read just about every suggestion from search engine sources to no avail I launched Onyx and did a number of things.

    1. I Repaired the disk permissions for system.
    2. I ran the daily, weekly, and monthly scripts for maintenance and
    3. Just for good measure I deleted the cashes in Safari and Internet - not my bookmarks or downloads but most everything else.

    This has fixed all my issues. Go figure!
  11. ncruz macrumors newbie


    Dec 4, 2017
    --- Post Merged, Dec 4, 2017 ---
    Thanks for sharing this tip. It worked for me!

Share This Page