Safari Causing Audio Issues?

Discussion in 'OS X Mavericks (10.9)' started by Lord Blackadder, Feb 22, 2016.

  1. Lord Blackadder macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #1
    This morning, my Mac Pro (Mid 2010, Mavericks 10.9.5) suddenly began producing choppy streaming audio and Safari became pretty sluggish. I figured it was a problem with the ISP until I tried using iTunes - and my local music library suffered the same audio playback problems.

    I narrowed the problem down to Safari - the choppiness only happens when Safari is running. No problems when running Chrome.

    The Activity Monitor showed hundreds of idle wakeups on the coreaudio process, not sure if that is related to the problem. I know Mavericks has had some audio issues, but this is the first time I've experienced it. Also, the option to stop plugins to save power in Safari is not checked, so that can't be the cause of the problem.

    Has anyone else experienced this? I'm probably going to uprgade the OS, but if I can fix this issue without doing so I will.
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    I would suggest disabling your Safari plug-ins and extensions. Probably one of them is causing the problem.
     
  3. Lord Blackadder thread starter macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #3
    I did that, and the problem went away. The odd thing is, I don't have any extensions, and the only plugins I had set to "allow" are sites I use often and never give me trouble. I wonder if the trouble came from one particular website...

    Thanks anyhow!
     

Share This Page