Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

bcodemz

macrumors member
Original poster
May 6, 2014
53
41
I just updated to OS X 10.11.3 from software updates, and my Safari is almost completely broken. When I create a new tab it doesn't show up. When I enter something on the URL bar, there is no auto-complete, and the URL shows up both centered and left aligned in the URL bar. Many pages, including Google will not load from the URL bar. I've tried quitting Safari and restarting, but it is the same thing. Any help? This is a huge problem.

Thanks
 
  • Like
Reactions: jenspeaks

JackBauer24

macrumors newbie
Aug 19, 2004
16
7
I am having this problem on 10.11.2

Disabling 'search engine suggestions' in Prefs seems to fix it.
 
  • Like
Reactions: arn

theriddler

macrumors regular
Dec 6, 2011
110
42
UK
The autocomplete works in Incognito mode.

Anyone else had AJAX websites not load when you click something or scroll down? Been having this issue since Yosemite.
 

quackers82

macrumors 6502
Mar 13, 2014
340
168
I don't think its the update, I'm seeing it here on multiple Macs using 10.10.5 and iPads on iOS 9. I know of another place thats seeing this issue too. So not sure what it is. Only happening today.
 

kolax

macrumors G3
Mar 20, 2007
9,181
115
I've been using 10.10.3 since release and this issue has just happened now. I imagine the autocomplete might be talking to iCloud so there's an issue there..

Though the tab interface is all screwed too. Who knows. Was fine yesterday.
 

Oh-es-Ten

macrumors regular
Aug 14, 2007
200
67
London
70% of our Macs in our office have this issue, kind of wiped us out this morning. As mentioned above fixes are disabling search suggestions and also Private Browsing as well.
 

Airmaxone

macrumors newbie
Jan 27, 2016
21
2
It was working fine today until this happened.What's happening?

CZuCNh7UAAAwUYc.png:large
 

solidsn2004

macrumors newbie
Oct 30, 2014
25
17
Milan
Guys I have the same problem here! It was working fine last night but it stopped working this morning!
I did a scan with Malwarebytes Anti-Malware software and it found a few viruses in the safari libraries and I removed them but the problem persists! I can't click on the search bar unless I am in incognito mode and I can't open new tabs (it looks like it's opening a new invisible window instead of a tab but I still can't type inside the search bar).

I also noticed that safari on my iPhone 6 doesn't work either! When I click on the address bar the app crashes!

What is causing this? It's really weird!!!
 

rcooked

macrumors regular
Feb 3, 2015
210
376
Driving me nuts as well. Always enjoyed the Safari experience, but going to have to run with Chrome until fixed. It's basically unusable....
 

maflynn

macrumors Haswell
May 3, 2009
73,590
43,578
This just raised its ugly head on my mac. I thought it was perhaps a bad plist, or plug-in but after mucking around with it this morning, I can say its none of those.

The Safai suggestions may have been what fixed this, as I turned off a bunch of stuff and its now working
 

Marshall73

macrumors 68030
Apr 20, 2015
2,680
2,776
This just raised its ugly head on my mac. I thought it was perhaps a bad plist, or plug-in but after mucking around with it this morning, I can say its none of those.

The Safari suggestions may have been what fixed this, as I turned off a bunch of stuff and its now working

Yep, seems to be the case. Looks like an issue with Apples servers.
 

Sabretooth78

macrumors member
Nov 13, 2012
66
41
Western NY
Just noticed similar issues last night myself - and just before updating to x.x.3, too - the address bar would get all goofy as in post #11 (though not quite as unreadable) and that particular Safari window would stop accepting keyboard input, either in the address bar or any forms on the page. I first thought it might be my keyboard, but the USB keyboard wouldn't work either. Shortcuts such as cmd-w and cmd-n would still work though. Any new Safari window would then work properly - for a while. I'll try the fix this evening.

"It just works."
 

A.Chakery

macrumors member
Aug 27, 2011
78
8
Vienna, Austria
Maybe not relevant but I faced an another issue with this version of Safari which is about installing extensions that is not supported by apple ext. gallery :

Since I didn't want to distract the main topic here , I created an another topic about it (HERE)
 

Barnclos

macrumors newbie
Nov 15, 2015
26
15
Me too: 'return' not working and double entries on the address bar. Started after updating to 10.11.3 (although others' evidence suggests that isn't necessarily the cause).

Switching off 'Include search engine suggestions' fixed it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.