Safari Crash on Launch - DP5

Discussion in 'OS X Yosemite (10.10)' started by PsykX, Aug 5, 2014.

  1. PsykX macrumors 6502a

    PsykX

    Joined:
    Sep 16, 2006
    #1
    So I went from DP4 to DP5 yesterday and suddenly Safari stopped working for good, throwing this crash between 1 and 10 seconds upon launch :

    It's like it's trying to add the launch page from Safari into their history SQLite database, but they're injecting empty data. I do have a lunch page when I start Safari, it's not a blank page.

    Here's the crash log when I put in a blank page :
    I tried disabling extensions, deleting history, deleting preferences, etc. but nothing seems to fix the problem. I have an iMac 27-in from late 2013.

    Does anybody have a fix in mind ? Else I will just report it to Apple and cross my finger for a fix in DP6. I can't stand other browsers on the OS X platform.
     
  2. stoopkidblues macrumors regular

    stoopkidblues

    Joined:
    Mar 21, 2014
    #2
    Same issue here. I'm attempting a clean install but we may just be the unlucky beta testers this round. I'll let you know how it goes.
     
  3. hacra macrumors newbie

    Joined:
    Mar 6, 2013
    #3
    Same issue here. As soon as safari opens it starts loading the websites and crashes within 10s or so. It keeps crashing after the history was removed.

    Exception Type: EXC_CRASH (SIGABRT)
    Exception Codes: 0x0000000000000000, 0x0000000000000000

    Application Specific Information:
    Process Model:
    Multiple Web Processes

    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** setObjectForKey: object cannot be nil (key: INSERT INTO history_items (url, domain_expansion, visit_count, daily_visit_counts, weekly_visit_counts, autocomplete_triggers)VALUES (?, ?, ?, ?, ?, ?))'
    abort() called
    terminating with uncaught exception of type NSException
     
  4. PsykX thread starter macrumors 6502a

    PsykX

    Joined:
    Sep 16, 2006
    #4
    Ok I got some more info for you : it's either fixed in the next DP, OR Apple actually didn't understand what the person before me reported.
     
  5. hacra macrumors newbie

    Joined:
    Mar 6, 2013
    #5
    I have used the feeback assistant as well, and sent the safary and system diagnosis plus the crash report.

    I am sure others probably have reported as well.

    If i recall correctly there was a similar error before with keynote and i think it was related with how it handled the user fonts...

    tried to disable user fonts and use the fix that worked for keynote to no avail.

    So i guess we will have to wait for extra news.
     

Share This Page