Safari crashes almost right after launch

Discussion in 'Mac OS X Lion (10.7)' started by arjen92, Oct 19, 2011.

  1. arjen92 macrumors 65816

    arjen92

    Joined:
    Sep 9, 2008
    Location:
    Below sea level
    #1
    He,

    I upgraded from 10.7 to 10.7.1 using pacifist (the installer wouldn't want me to install it for some odd reason). Then I installed 10.7.2. with apple's installer. When I opened safari it would open my facebook and have no problem surfing around facebook. However as soon as I would go somewhere else (e.g. macrumors.com) it would crash. So I tried resetting safari in the menu options, turning of plugins, trying to delete them (but I don't have any plugins, so that doesn't help), deleting preference files, all to no avail.

    I "reset" it to the point it gave the introduction video "welcome to safari etc". But now when I open it, it asks if I want to restore my windows, whether I choose restore or not, safari "flies in" (as it opens, the nice animation) halfway it freezes and crashes. Below is the Crash report. I installed Chrome (using a thumbdrive to put it on my macbook pro 2010). And Chrome is working.

    Oh, almost forgot I also downloaded the installer for safari (5.1.1), it starts installing but then tells me it stopped the installation after encountering problems. So I tried pacifist, but it gives me errors as well.

    So, does anybody know how to fix this?

    (p.s. not so good with the forum, how can I get the crash log on here? It's too big)
     
  2. Tiki35 macrumors 6502

    Joined:
    Oct 25, 2009
    Location:
    Nanoose Bay, BC, Canada
    #2
    If you create a new "test" user account, does it do the same thing?
     
  3. arjen92 thread starter macrumors 65816

    arjen92

    Joined:
    Sep 9, 2008
    Location:
    Below sea level
    #3
    I got it to reinstall safari 5.1.1. It's working again.
     

Share This Page