Safari crashes on launch-Leopard Log file included

Discussion in 'macOS' started by jburns, Nov 4, 2007.

  1. jburns macrumors regular

    Joined:
    May 1, 2007
    Location:
    NC-USA
    #1
    Safari crashes immediately after attempting to launch. Running Leopard. Can anyone help out? Here is the log file.

    Process: Safari [279]
    Path: /Applications/Internet/Safari.app/Contents/MacOS/Safari
    Identifier: com.apple.Safari
    Version: 2.0.4 (419.3)
    Build Info: WebBrowser-4190300~31
    Code Type: X86 (Native)
    Parent Process: launchd [93]

    Date/Time: 2007-11-04 17:07:55.661 -0500
    OS Version: Mac OS X 10.5 (9A581)
    Report Version: 6

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Symbol not found: ___commpage_dsmos
    Referenced from: /Applications/Internet/Safari.app/Contents/MacOS/Safari
    Expected in: /usr/lib/libSystem.B.dylib
     
  2. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
    #2
    I don't know much about logs, but this seems to be Tiger's Safari version...
     
  3. bikeman99 macrumors newbie

    Joined:
    Nov 4, 2007
    #3
    Safari Crashes

    I am having the same problem. The only way I can access Safari when this happens is to reboot. That seems to work for a while then for no apparent reason the problem returns. I though it might be related to Time Machine and turned that off, but the problem still persists. Nice to know I am not the only one experiencing his frustration.
     

Share This Page