Safari Died

Discussion in 'Mac Apps and Mac App Store' started by MacYang, Jan 17, 2007.

  1. MacYang macrumors newbie

    Apr 15, 2006
    Hey everyone,

    Just out of the sudden my safari can't connect to the web. I get a message: "Safari can’t open the page “” because it could not connect to the server “”.". I reset safari, trashed the .plist, did a 10.4.8 combo update reinstall, used pacifist to replace safari, run onyx, created a new account but it still hasn't solved it. The weird thing is that mail, firefox/camino and my IM clients work fine, and my network diagnostics show that I m connected.
    Something that is also related is that my widgets have also lost their web connection.

    Any suggestions besides an archive/fresh system install?

    I know you guys can figure this out :p
  2. clevin macrumors G3


    Aug 6, 2006
  3. psychofreak Retired


    May 16, 2006
    Try repairing permissions (in disk utility)

    Have you tried other websites?
  4. MacYang thread starter macrumors newbie

    Apr 15, 2006
    Tried the nightly build. Same problem on any website I connect to.
    Seems very strange to me, since all other browsers work. It's just safari and the widgets. What part of the OS have they both got in common?
  5. clevin macrumors G3


    Aug 6, 2006
    i cant' figure it out, seems u have tried everything.
    1. firefox is not bundled with system, and it works
    2. camino uses some system features, and it works
    3. webkit have different shell files, and it works

    so, ur problem, probably, related to some settings/problems in OSX, exactly? i dont know.....
  6. MacYang thread starter macrumors newbie

    Apr 15, 2006
    You guys think its possible it could be a problem with my internet provider?

    I am puzzled since everything works besides safari and widgets.
  7. clevin macrumors G3


    Aug 6, 2006
    i dont think so, if there is something wrong with your internet service provider, firefox should have the same problem.
  8. axboi87 macrumors regular


    Aug 31, 2006
    Dallas, Tx

    Try safari under another account, if it works there then clear out your input manager folder (it's in the Library under your home folder)

    Also, and this sometimes fixes weird problems, I was having a printer issue and this fixed it somehow. Cmd+option+p+r at the boot chime, keep holding until you've heard the boot chime three times. Let it boot then restart again this time holding cmd+option+o+f at the chime. At the prompt type:
    then hit enter. then type
    hit enter, the computer will restart. Try that. Also you could try resetting safari by clearing out any .plist files related to it
  9. clevin macrumors G3


    Aug 6, 2006
    other than reset PRAM and firmware, i think he already tried other two u mentioned, i would be surprised if PRAM or firmware are the cause of the problem... but, never hurt to try...:D

Share This Page