Safari disable form autocomplete

Discussion in 'Web Design and Development' started by al404, Jun 13, 2016.

  1. al404 macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #1
    I have an issue with safari, on a form it autocomplete email field even if it is already filled with a different email
    For autocomplete i mean when background field color change to yellow

    I'm not sure why it does it since field is not even empty
     
  2. smirking macrumors 6502a

    Joined:
    Aug 31, 2003
    Location:
    Silicon Valley
    #2
    Yeah, unfortunately Safari does this. Most of the time it's ok with me, but there are a few sites where this behavior royally messes me up and I have to turn off autocomplete for usernames and passwords or for Contact info.
     
  3. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #3
    noway to add some attribute to input field for disable it on client side?
     
  4. smirking macrumors 6502a

    Joined:
    Aug 31, 2003
    Location:
    Silicon Valley
    #4
    I'm not sure what you're asking. Are you asking if it's possible to code the input form in a way so that Safari will not attempt to autocomplete it? Or do you mean is there some way to suppress it momentarily without changing your preferences?
     
  5. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
  6. smirking macrumors 6502a

    Joined:
    Aug 31, 2003
    Location:
    Silicon Valley
    #6
  7. 960design macrumors 68000

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #7
    Safari > Preferences > Autofill > Uncheck them all

    I use <input ... autocomplete='false'> on each input field, seems to work for most browsers.
     
  8. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #8
    @960design is not something i'm looking client side, what i was looking for was a solution in code
     
  9. 960design macrumors 68000

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #9
    <input ... autocomplete='off'>
    https://www.w3.org/TR/2011/WD-html5...nt-attributes.html#the-autocomplete-attribute

    Oops! I was just plain wrong, should not be 'false', should be 'off'. I believe I used false to try to get Safari to work in the past and maybe it worked?

    There were issues with Safari in the past, maybe that is why I tried 'false'.
     
  10. smirking macrumors 6502a

    Joined:
    Aug 31, 2003
    Location:
    Silicon Valley
    #10

Share This Page