Safari displaying strange type symbols.

Discussion in 'Mac OS X Lion (10.7)' started by gugy, Jul 26, 2011.

  1. gugy macrumors 68030

    Joined:
    Jan 31, 2005
    Location:
    La Jolla, CA
    #1
    Hi,
    Since I update to Lion, several websites under Safari display these weird characters. How do I get rid of them and go back to normal viewing?
    I notice if I disable some fonts like Arial (maybe duplicates) it help a bit but doesn't go away entirely.
    I appreciate any feedback if anybody encountered this problem and found a solution.
     

    Attached Files:

  2. brijazz macrumors 6502

    brijazz

    Joined:
    Jul 31, 2008
    #2
    I had the same problem after installing MS Office 2011. I did a "resolve duplicates" in Font Book, and followed with a simple reboot to fix the problem.

    This was under 10.6.8... don't know if Lion will give the same result.
     
  3. gugy thread starter macrumors 68030

    Joined:
    Jan 31, 2005
    Location:
    La Jolla, CA
    #3
    yeah, it seems like a font duplicate issue. The weird stuff it was fine under Snow Leopard, it just started to happen in Lion. I wonder if Lion installed new fonts thus the issue.
    Trying to figure out how to eliminate all duplicates on Font Book. I did use the comand under the menus it did find few duplicates but the issue persists.
    Annoying thing.
    Thanks for the tip.
     
  4. pnwdesigns macrumors newbie

    Joined:
    Feb 25, 2014
    #4
    Strange Character Problem!

    the same thing was happening to me safari yahoo email, some web pages in firefox and then adobe illustrator all of a sudden after adding fonts. i tried checking the allow pages to choose their own fonts... and that kind of helped but not everything. i tried clearing the cache in firefox and then in safari but that didn't help. then i tried validating my fonts and cleared the duplicates and that didn't help. i even got rid of the newly additional fonts added but no go, rebooted each time. THEN finally i found online that i needed to clear the font cache. downloaded font finagler (shareware) and now all the odd characters went away even in my adobe illustrator!! here is the link http://www.markdouma.com/fontfinagler/. there are other font cache cleaners but this one worked for me.
     

Share This Page