Safari elements 'freezing'

Discussion in 'macOS' started by iTom17, Jun 26, 2016.

  1. iTom17, Jun 26, 2016
    Last edited: Jun 26, 2016

    iTom17 macrumors 6502a

    iTom17

    Joined:
    Aug 2, 2013
    Location:
    the Netherlands
    #1
    I've been having an issue for quite a while now and it doesn't seem to have been fixed with macOS Sierra. So I decided to bring it to MacRumors. :p

    So, in Safari after a certain amount of time, elements on a website some kind of freeze. For example, just a few minutes ago when I was at Facebook elements wouldn't 'animate' (when hovering over like button to get those extra options e.g.). This happens quite a lot. Not on every website opened at once, but mostly just one or sometimes two. I can however click by the way, it's really that the animation is gone.

    The thing is that restarting Safari sort of fixes the issue. But then again, after a certain amount of time it happens again. I have no idea what causes this and would like to know if others are having the same issue, as well as whether there's a more permanent solution?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Problems of this sort are usually caused by out-of-date or incompatible Safari extensions or plug-ins. You could try disabling your extensions from Safari Preferences > Extensions. To disable Plug-ins, you have to remove them from these two folders:

    ~/Library/Internet Plug-ins (where ~ means your home folder)
    /Library/Internet Plug-ins

    You could also check your Console Logs for the time of the freeze to see if there are any error messages from Safari or an extension or plug-in.
     

Share This Page