Safari font sizes on a 27" screen

Discussion in 'iMac' started by T'hain Esh Kelch, Oct 24, 2013.

  1. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #1
    How do you guys handle the size of fonts, so they are readable? I have my 27" iMac about 1 meter from my face, and I am having trouble getting Safari to suit my needs.

    If I set the preferences to force a minimum font size of 14, then the text is too small. If I set it to 18, then I can read everything, but all pages doesn't render correctly, and I have to press command-+ to make everything scale properly and fit the text.

    I am missing some form automatic zoom function, or just make Safari render everything based on the font size.
     
  2. fizzler macrumors member

    Joined:
    Jul 5, 2010
    #2
    I had a similar issue with Safari and am now using chrome for browsing on all my devices, as it allowed me to auto-set the zoom to 110%.

    Someone will no doubt have an actual safari solution for you, but I got sick of cmd + all the time.

    I much prefer chrome now.
     
  3. fhopper macrumors member

    fhopper

    Joined:
    Sep 18, 2007
    Location:
    Wichita Ks.
    #3
    This is the downside of LCDs they really look their best in their native res. I bounce back and forth between the native res and scaling back one level in the display prefs depending on what I am doing. With the display icon in the menu bar it makes it relatively painless.
     
  4. NewbieCanada macrumors 68030

    Joined:
    Oct 9, 2007
    #4
    1. double-tap with two fingers to zoom and unzoom.

    2. Type in whatever minimum font size you like. You're not limited to what's in the list.
     

    Attached Files:

  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Install the Quickstyle extension for Safari and you can set it to enlarge text on some or all pages you visit. Works great.
     
  6. T'hain Esh Kelch thread starter macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
  7. FLOKER macrumors newbie

    Joined:
    Jul 10, 2012
    Location:
    Germany
    #7
  8. T'hain Esh Kelch thread starter macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #8
  9. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #9
    None of these are solutions, sadly. Allpageszoom is annoying since you see every page resize itself after it's loaded. And the .css modification causes some havoc on many pages with pop-up clickable areas not where they should be, or e.g. the gmail web page not showing you the settings bar etc at the top of the page.

    I've yet to find a good solution for 120% text size in Safari, permanently, without CMD+ on every pager manually.
     
  10. fhopper, Oct 25, 2013
    Last edited: Oct 25, 2013

    fhopper macrumors member

    fhopper

    Joined:
    Sep 18, 2007
    Location:
    Wichita Ks.
    #10
    Uh, my solution works and it does not blow up HTML.
    Select 2048x1152 and the text size issues go away.
     

Share This Page