Safari forgets how to connect to websites.

Discussion in 'OS X El Capitan (10.11)' started by Spytap, Sep 15, 2015.

  1. Spytap macrumors member

    Joined:
    Oct 8, 2010
    #1
    Noticed this throughout the beta, but Safari seems to be suffering from some sort of intermittent DNS issues, where it'll occasionally just forget how to connect to any site for a bit. Chrome and Firefox will still work perfectly during this period of time, but Safari will just...not be able to connect, taking forever to find Youtube.com Or Cnn.com Or even Google.com

    Anyone else seeing this? Anyone have a fix? It'll happen once or twice a day, for about 3-5 minutes at a time. It's not a huge hassle because I just switch over to Chrome until it resolves itself, but it's still weird and kind of annoying.
     
  2. registered macrumors member

    Joined:
    Feb 6, 2006
    #2
    Same issue here. Happens pretty regularly in Safari on El Capitan GM.
     
  3. patternjake macrumors member

    patternjake

    Joined:
    Sep 17, 2015
    #3
    Hmm, not having that issue here, try switching to Google or OpenDNS if that helps.
     
  4. Spytap thread starter macrumors member

    Joined:
    Oct 8, 2010
    #4
    Odd. I do use Google DNS.
     
  5. Spytap thread starter macrumors member

    Joined:
    Oct 8, 2010
    #5
    Interesting additional info:

    When a Safari window is unable (unwilling?) to connect to any website, I can Command+N open a new Safari window, and that new Safari window will work perfectly, while the other window continues to be unable to connect to any website for several minutes further.
     
  6. registered macrumors member

    Joined:
    Feb 6, 2006
    #6
    Seems like a lot of us are still having this issue regardless of the DNS server. I even tried disabling all Safari extensions and it still seems to occur.

    I think something may be funny with Safari in the El Capitan GM or maybe the preferences are somehow corrupted.
     

Share This Page