Safari freeze on textbox focus

bhagowal83

macrumors newbie
Original poster
Sep 18, 2019
9
2
Melbourne
Hi,

Versions my Mac is on:
Mac OS Mojave 10.14.6
Safari 12.1.2

I tried to search this forum for the specific problem that I am having. Safari freezes as soon as I am about to login into Google username. The rotating rainbow icon freezes the whole application. NO issues with youtube search box. Again, I was logging into a government website here in Australia with my account, again Safari froze. I have tried to refresh cache but it has not helped.

Am I missing something here ?
Has anybody else encounteres such a weird issue with Safari ?

Regards,
B Singh
 

mpainesyd

macrumors 6502a
Nov 29, 2008
613
132
Sydney, Australia
Don't get your hopes up!
I "updated" to Safari 13.0 (Mojave) today and it has frozen twice already. When it freezes it also prevent me from clicking on the Apple icon to access the Force Quit menu item. I have to use Option-Command-Esc to force quit safari.
I am not using any extensions.
It has also given some odd responses when trying to fil in text boxes.

Grrr
 

CPx

macrumors 6502a
Sep 6, 2013
546
264
Trouble with all text boxes or just login boxes? If it's just login boxes maybe it has to do with account autofill, or perhaps keychain. If so maybe try turning off autofill (and/or keychain) to narrow down the problem.
 
  • Like
Reactions: bhagowal83

bhagowal83

macrumors newbie
Original poster
Sep 18, 2019
9
2
Melbourne
Trouble with all text boxes or just login boxes? If it's just login boxes maybe it has to do with account autofill, or perhaps keychain. If so maybe try turning off autofill (and/or keychain) to narrow down the problem.
it is with specific textboxes like google login. no issue with yahoo login. bit weird !!
 

bhagowal83

macrumors newbie
Original poster
Sep 18, 2019
9
2
Melbourne
Trouble with all text boxes or just login boxes? If it's just login boxes maybe it has to do with account autofill, or perhaps keychain. If so maybe try turning off autofill (and/or keychain) to narrow down the problem.
This solved the problem for me.

Go to Safari -> Preferences -> Autofill
and uncheck all checkboxes. You might uncheck one by one and see which one is giving you trouble. I unchecked all, however, as I didn't need that functionality.

Thanks CPx.
 
  • Like
Reactions: CPx