Safari freezing up

Discussion in 'OS X Mavericks (10.9)' started by slomo86, Oct 23, 2013.

  1. slomo86, Oct 23, 2013
    Last edited: Oct 23, 2013

    slomo86 macrumors member

    slomo86

    Joined:
    Jul 30, 2008
    Location:
    Turkey
    #1
    Has anyone else experience safari freezing after trying to access the preferences? Mine is seeming to freeze right after I try to access the website push notifications and add on tabs. After closing the preferences the safari window goes grey and cannot close anything, but the menu bar still works and I am able to close safari and reopen again.

    Anyone else experiencing anything similar?

    EDIT:

    I been playing with it more trying to figure out what exactly it is doing, and I keep getting this:

    It is not completely freezing up, it is unresponsive for a minute and then I can go about my business but the annoying part is the window looks like it is still the inactive window. Also in preferences in the notification tab and , where the websites are supposed to be it shows what ever window is in the background. Then I have a heck of a time trying to get preferences to close once it does I can not get it to open back up.
     
  2. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #2
    I'm getting some weird freeze-like behavior, but it's triggered by something different. I'm using the Magic Trackpad, and sometimes when I swipe backward to go back then the page slightly shifts over but then it stops. At that point scrolling in that tab by finger swiping is completely broken; I can scroll with the keyboard or by clicking and dragging the scroll bar, but that's it.

    Of note, this has happened in Chrome once as well, but it seems to occur in Safari more often. What I'm describing may be an OS X issue, and not a Safari problem.
     
  3. Jschultz macrumors 6502a

    Jschultz

    Joined:
    Mar 14, 2005
    Location:
    Chicago, IL
    #3
    I'm getting the same thing. If 'swipe' to page back, it freezes and hangs. If anyone figures out what's causing it, please post here.
     
  4. ValeryK macrumors newbie

    Joined:
    Nov 7, 2013
    #4
    Safari freezing up

    This is happening to me also. It started after I upgraded to Maverick.
     
  5. macred macrumors regular

    Joined:
    Oct 8, 2013
    Location:
    LAX & beyond
    #5
    Same issue here. Fortunately Chrome is fast and my fav by a mile :)
     
  6. TayHarley macrumors member

    TayHarley

    Joined:
    Mar 14, 2008
    #6
    same here Safari freeze - unresponsive totally - then starts jumping though the various 'click attempts'. Only since Mavericks upgrade ! :confused:
     
  7. IgnatiusTheKing macrumors 68040

    IgnatiusTheKing

    Joined:
    Nov 17, 2007
    Location:
    das Fort
    #7
    I've noticed that when the Safari back swipe animation freezes up, it pretty much makes all gestures stop working in Safari (like scrolling) but not elsewhere in the OS (i.e. Finder), so it probably is a Safari issue.
     
  8. OmniDragon macrumors newbie

    OmniDragon

    Joined:
    Jul 14, 2010
    #8
    "Target remains. I repeat...target...remains." -Independence Day

    Well, it's been a couple months. I just thought I'd check and see if anybody else was experiencing this or if anybody found a fix for it or what. bumpetybumpbump help? :( I was kinda thinkin it was a coca app kinda thing? Cause the same thing happens in TweetBot when trying to swipe with 2 fingers on the trackpad to view replies to a tweet. Then, I have to quit tweetbot and relaunch in order for it to act right again. But, with Safari, doesn't matter if I quit it. Relaunching afterwards, the problem's still there. Opened up Activity Monitor, but there's no process in the red, nothing really looks out of place...but I don't know. I also don't know which process handles this gesture.
     
  9. OmniDragon macrumors newbie

    OmniDragon

    Joined:
    Jul 14, 2010
    #9
    Temporary Fix Possible...

    System Preferences > Trackpad > More Gestures

    Toggle the "Swipe Between Pages" checkbox. I had it on to begin with, so off and then on again. Came back to Safari, and was able to swipe back n forth to browse.

    Note: First thing I did was disable it. Then I came back to Safari, and made the gesture (swiping to browse back or forward) just to see if it would stick or not, noticing that the window goes smoothly to the left for wanting to browse forward, but that there was a little bit of a hiccup when going to the right for wanting to browse backward. It was like a stretching exorcise for the window. (tic) lol Anyway, after I did that, I went and toggled it back on, and now it works again. Wonder when it's going to stop working again. That's going to be key to figuring this out.
     
  10. dguay macrumors newbie

    Joined:
    Mar 10, 2014
    #10
    Having this issue as well. I had Jitouch installed and think this would cause the problem. People with same problem, are you using jitouch, magicprefs or any other application that enhance trackpad functionalities?

    I uninstalled Jitouch today and it seems like I don't have any problem with swiping back for now but we will see.

    My temporary solution is to put display to sleep like 2 seconds. When it comes back, I can swipe again.

    BTW, this bug happens in App Store as well.
     
  11. yadmonkey, Jul 4, 2014
    Last edited: Jul 4, 2014

    yadmonkey macrumors 65816

    yadmonkey

    Joined:
    Aug 13, 2002
    Location:
    Western Spiral
    #11
    This seems to have worked for me:

     
  12. Resist macrumors 68030

    Joined:
    Jan 15, 2008
    #12
    This didn't work for me.
     
  13. MarcusCarpenter macrumors 6502a

    MarcusCarpenter

    Joined:
    Feb 18, 2013
    Location:
    London
    #13
    When the Safari gesture crashes use this commend.

    sudo killall -HUP WindowServer

    It will log out - log back in and the issues gone
    (Until next time lol)
     
  14. stevenzli macrumors newbie

    Joined:
    Oct 22, 2015
    #14
    Yes, problem still persists after Yosemite and El Capitan updates, and I am pretty sure it is Jitouch now (other not using Jitouch have no such issue). Now facing the choice to disable Jitouch or live with such annoyance.
     
  15. dlfromm macrumors newbie

    Joined:
    Nov 17, 2016
    #15
    I have had a problem with Safari Freezing on my IMAC running El Capitan 10.11.6. This has been a daily issue several times a day. I downloaded CleanMyMac 3 and installed the free version and let it clean the crap off the hard drive. I do not advertise a product and am a IT Pro (retired) but this seems to have cured the problem. I've had my MAC for 5 years and am still learning it. Try it and see if it works for you because it can drive you crazy. I even installed Fire Fox to get around the issue but apparently there was something in my software and it also corrupted it. I have Sophos and Malwarebytes loaded also.
     

Share This Page