Safari, Front Row, and Network problems..

Discussion in 'Mac Apps and Mac App Store' started by cashel, Jul 1, 2007.

  1. cashel macrumors member

    Joined:
    Oct 30, 2006
    #1
    I've got a few problems that over the last few days have become pretty annoying.

    The first is Safari out of nowhere has completely stopped working. When I open it and let it load a web page, any web page, it will quit unexpectedly after about 10 seconds. Firefox works fine, I'm on it now. I've cleared caches, reset settings, repaired permissions, etc. Nothing works.

    The second problem is with Front Row. When I try and fast forward for more than a few seconds through a movie, Front Row completely quits on me. The only movies I've tried so far are Divx and Xvid movies, but those are the only ones I have on this laptop.

    Finally, is there a way to have a OS X connect to a networked drive automatically on startup, and search for that drive if it isn't connected or lost the connection?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Well, I can answer the network drive question: There are actually a number of different ways, some involving Applescript, but the easiest is this:

    Connect to the drive. Open the Accounts preference pane. Go to the "Login Items" tab for the user you want the automount to be on. Drag the mounted volume into the list. You're done.

    Basically this will attempt to open the relevant drive, which causes the Finder to automatically connect, so long as you've got your password saved in the keychain.

    As for reconnecting if you're just logged in and working, I usually stick the volume in my dock and just click on it--that works fine.

    The other two problems:

    Have you tried creating a fresh account and seeing if the problems happen there? if so, that's a bad sign--either you installed something in the system Library (Quicktime or Internet plugin, maybe?) that is causing the crashes, or you've got more serious issues with your OS install.

    If the problems DO occur in a fresh account, try removing any plugins or system hacks you recently installed. If there are none, or that doesn't do it, sounds like reinstall time. (I've seen one computer badly enough munged that this was required, and the symptoms on Safari were similar.)

    If the problems don't happen in a fresh account, you've either got something installed in that user's library (again, plugins maybe?), or some screwed up pref files.

    Good luck.
     

Share This Page