Safari + Google + 2 Factor = Not Working

Discussion in 'OS X Yosemite (10.10)' started by Dark54555, Jan 22, 2015.

  1. Dark54555 macrumors newbie

    Joined:
    Oct 5, 2011
    #1
    Just upgraded my wife's mac pro to OSX10.10. Since the upgrade, whenever she logs into Google, it prompts her for her 2 factor every. single. time. Even if you check the "Remember me for 30 days" box, it still prompts her again the next time she goes to log in. Any idea what the problem is? I don't use Safari on my Macbook, so I haven't had the same issue since the upgrade.
     
  2. Dark54555 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #2
    anybody? Her Safari didn't do this in Mavericks, ever. It's totally a new issue since the upgrade.
     
  3. Natzoo macrumors 65816

    Natzoo

    Joined:
    Sep 16, 2014
    Location:
    Not sure where i am
    #3
    Yes, that happens to me. Not sure how to fix it unless you want to downgrade. But for me it usually requires me to press the down key and the password will just pop up
     
  4. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #4
    Does she have two factor authentication on her Apple account turned on? If so, is she using Google to access any of her Apple accounts? If she is, that could be what you are describing. It would be a good idea to go to the AppleID website and check the two-factor status.
     
  5. Dark54555 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #5
    Nope. This is simply Open Safari --> gmail.com --> login.

    That login requires the second factor every time, even if you tell it to remember the second factor part. It didn't do that in 10.9, and now it does 10.10.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    I think Yosemite made some changes to how cookies are handled and I wonder if that is causing this? I have 2FA turned on for Gmail and I am not seeing this issue.

    Here is how my cookies are set. If you are not allowing the cookie to be saved, I think that might make you authenticate every time.

    [​IMG]
     
  7. Dark54555 thread starter macrumors newbie

    Joined:
    Oct 5, 2011
    #7
    Those are exactly the settings she has, which is part of why this is so confusing.
     

Share This Page