Safari Google keeps going to Japanese

Discussion in 'OS X Yosemite (10.10)' started by HaruAoki, Jun 24, 2015.

  1. HaruAoki macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #1
    Hello, for the past hour Safari is no longer going to www.google.com instead it going to www.google.co.jp when ever search things in the search bar but when I hit the home button it will sometimes take me to www.google.com and other to www.google.co.jp

    Does anyone know why this is happing and or how to fix the issue?

    Thank you for your time and I hope you all have a great day/night.
     
  2. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #2
    I found out how to fix it, seach somthing in google the school down to the botton there will be a use location button at the botton clicking will bring up a pop up menu asking to use your loaction allowing it will then fix the problem making google to go to the right one.

    This looks like it work i will comment more if this still happend.
     
  3. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #3
    I'm still having the issue I also have a bootcamp verson of windows 7 on it to with this same problem happaning. I' ve been looking around could this problem be a google redirect virus?
     
  4. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #4
    I gont think its a virus since it is happning on all other computer and phones and tablets.
     
  5. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #5
    Going to www.google.com/ncr has seemed to fix this problem on all devises (so far) will comment back in a bit to say if it's still working or if it's still going to .co.jp
     
  6. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #6
    Also getting the same problem on youtube and the ios youtube app where i'm getting Japanese ads.
     
  7. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #7
    Update: even tho Gooogle is niw going back to .com insted of .co.jp all ads on google is japanes ones (just like in youtube) this happens in all browrses pc, mac, ipad and iphones...

    One this is fix but I dont know how to fix the ads but might not even be a problem.
     
  8. HaruAoki thread starter macrumors member

    HaruAoki

    Joined:
    Oct 14, 2014
    Location:
    Australia
    #8
    Still having the issue with no luck to fix it...
     

Share This Page