Safari - Google search results in foreign language

Discussion in 'Mac Apps and Mac App Store' started by MagicBoy, May 20, 2007.

  1. MagicBoy macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #1
    I've got a wierd problem with Safari - search for something using the Google search bar thingy and the results are coming back in a foreign language in a non-english alphabet. Firefox works fine.

    Any ideas how to fix it?
     
  2. siurpeeman macrumors 603

    siurpeeman

    Joined:
    Dec 2, 2006
    Location:
    the OC
    #2
    you can do it in the google preferences, disabling results other than english.
     

    Attached Files:

  3. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #3
    It's in the google preferences. Hold on...I know there's an awesome thread on this. Lemme find it.

    Edit: Here is the thread...it covers Russian, but the general steps apply if Google is completely in a language you don't understand. Feel free to post screen shots if you need help finding English in the list of languages.
     
  4. MagicBoy thread starter macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #4
    Had a look at the google preferences, but I've no idea what any of it means. It's in greek/cyrillic/hebrew or something...
     
  5. MagicBoy thread starter macrumors 68040

    MagicBoy

    Joined:
    May 28, 2006
    Location:
    Manchester, UK
    #5


    Nice one - thanks. It was a similar language to the one in this thread.

    All fixed now. :)

    Any idea what caused it?
     
  6. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #6
    Not really...I've had it switch to Spanish when I had my systemwide language preference as Spanish, but it's happened to others without having that be the case.
     

Share This Page