Safari Hangs - Need to hit Enter Twice to Load Sites

Discussion in 'macOS Sierra (10.12)' started by Jay42, Dec 12, 2016.

  1. Jay42 macrumors 65816

    Jay42

    Joined:
    Jul 14, 2005
    #1
    If I enter in a new URL into Safari and hit enter, it loads maybe 1/5th of the way and hangs. Progress bar stops, browser window is blank. If I click into the URL bar and hit enter again (or refresh), it loads normally.

    Anyone else have this issue? It's a total deal breaker for me. I am going back to chrome until I can figure this out, which is too bad because I was enjoying the new features/optimizations of Safari.

    I'm running 10.12.1 with Safari 10.0.1 (12602.2.14.0.7) on a new 2016 13" TB MBP (2.9ghz i5, 16gb, 1TB).
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    I have seen a suggestion elsewhere to disable Safari web prefetching using the following terminal command:

    defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false
     
  3. heytommy macrumors newbie

    heytommy

    Joined:
    Jan 24, 2017
    #3
    I am experiencing this issue as well. Any fix so far?
     
  4. Woofie2010 macrumors member

    Woofie2010

    Joined:
    Dec 11, 2010
    Location:
    Australia
    #4
    Me too!
    I have this issue
     
  5. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    try creating a new location (system preferences>network) and re-sign in to your wifi network (or whatever)...
     
  6. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #7
    my post above (#5) worked for me 2 days ago, worth trying...
     
  7. MiniDave macrumors newbie

    MiniDave

    Joined:
    Sep 17, 2014
    #8
    For me, the problem was from Safari trying to find its own suggestion for my search, but not finishing before I press enter. That causes a bug where it does nothing when I press enter the first time. To fix it, go to the Search tab in Safari Preferences and turn off 'Include Safari Suggestions'. It will still show recent/common URLs and top google results, but it doesn't show Safari's own suggestion at the top (which is useless anyway).
     
  8. baas macrumors newbie

    Joined:
    Dec 20, 2016
    Location:
    Amsterdam NL
    #9
    This seems to have fixed it for me too.
     
  9. Scott_imac macrumors newbie

    Joined:
    May 2, 2017
    #10
    This worked for me too. Thanks
     
  10. ThinkMattClark macrumors newbie

    ThinkMattClark

    Joined:
    May 4, 2013
    #11
    THIS WORKED for me!
     

    Attached Files:

Share This Page