Safari hangs on secure sites

Discussion in 'Mac Apps and Mac App Store' started by turtleman14789, Jun 8, 2010.

  1. turtleman14789 macrumors newbie

    Joined:
    Jul 26, 2006
    #1
    When I start up Safari and load my home page (google.com/ig) it takes way to long (>30 seconds). After doing some testing I found out that Safari seems to be hanging when I make secure requests. I found that out by removing the Gmail and Google Calendar gadgets from my home page and it loaded right away. But then when I go to gmail.com and log in I have to wait again. Also at that time I can't use any other tabs, they all just sit there and spin like they are loading.

    Has anyone else had this issue? I know its a Safari issue because Chrome it just fine. Any ideas?
     
  2. applematt74 macrumors newbie

    Joined:
    Jun 9, 2010
    #2
    I am having the same problem, the browser hangs with igoogle and bizarrely me.com. It hangs when logging in.
     
  3. manwithaband macrumors newbie

    Joined:
    Jul 21, 2007
    Location:
    Griffin, GA
    #3
    Yes, I'm having the same issue. Safari 5 locks up whenever my iGoogle homepage loads. I have a Gmail and Google Reader widget on my homepage and Safari gives me the awesome little rainbow pinwheel every time I load it for the first time.

    This didn't start happening until I installed Safari 5...

    Any ideas for solutions would be appreciated.
     
  4. Blaine macrumors 6502a

    Blaine

    Joined:
    Dec 3, 2007
    Location:
    Abilene TX
    #5
    Been having the same issue here for forever.

    I guess safari doesn't like https:// connections.

    My homepage is gmail.com, and it hangs for maybe 10 seconds on the first browser launch after turning on or rebooting my mbp.

    Anytime after that, I can close safari and reopen it without the hang.

    It's a minor inconvenience that I wish Apple would somehow address.
     
  5. Wie Gehts macrumors 6502

    Joined:
    Mar 22, 2007
    #6
    This issue just started happening to me. At least its kinda good to know that its not specific to my system.

    Half then pages I go to Safari stalls opening the pages. This is just absolutely ridiculous.

    I'll use Firefox instead I guess
     

Share This Page