Safari hangs (spinning ball) 5 seconds after opening. Help?

Discussion in 'macOS' started by tbgsav, Jul 7, 2011.

  1. tbgsav macrumors newbie

    Joined:
    Jul 7, 2011
    #1
    I have exhausted my knowledge, time for some community help

    I have a Macbook Pro 10.5.8 with Safari 5.0.5. Everything except the issue works great!

    Problem:

    When I click to open Safari, it opens, loads the startpage and then hangs about 5 seconds later. The whole computer isn't usable until I force quit Safari.
    Every 15 seconds or so it returns to 'normal' and I can click a menu, switch applications, try to Force Quit Safari, but the spinning ball returns and everything hangs 2 seconds later.
    I can use Firefox with no issues, unless Safari is still open.

    What I have tried:

    Inplace reinstall of OS X from CD.
    All the Software Updates
    Reinstall Safari from apple website.
    Reset Safari
    Empty Cache
    Everything from this post (https://discussions.apple.com/message/10671044#10671044)
    Everything from this post (http://forums.macrumors.com/showpost.php?p=8413681&postcount=6)


    All to no avail, still same issue.
    Any help or ideas?

    Thanks!
    -tbgsav
     
  2. spidey3 macrumors regular

    Joined:
    Jul 1, 2010
    #2
    Are there any errors in /var/log/system.log or in /var/log/kernel.log when the problem occurs?

    What do you have in /Library/Internet Plugins? I have seen hangs like this from faulty / old plugins...
     
  3. tbgsav thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #3
    I have removed that plugin folder all to together.

    Update: Still no luck under the current user. I created a test admin account and Safari works fine under the new account. Is there a way to bring the clean/working/new Safari setting/info to my old account?

    Checking the log files now...
     
  4. spidey3 macrumors regular

    Joined:
    Jul 1, 2010
    #4
    Try shutting down Safari, then delete the following:
    /Users/<user>/Library/Caches/com.apple.Safari
    /Users/<user>/Library/Caches/Metadata/Safari
    /Users/<user>/Library/Preferences/com.apple.Safari.plist
    /Users/<user>/Library/Preferences/com.apple.Safari.RSS.plist
    /Users/<user>/Library/Safari

    Note: You will lose all of your bookmarks, RSS subscriptions, etc...

    Spidey!!!
     
  5. tbgsav thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #5
    Well, I swore I did all those, maybe except the "/Users/<user>/Library/Caches/com.apple.Safari" one, but all is well now! Browsing great. Thanks!
     

Share This Page