Safari Individually Remove URL History

Discussion in 'macOS' started by theelysium, Jun 10, 2011.

  1. theelysium Suspended

    theelysium

    Joined:
    Nov 18, 2008
    #1
    HI Y'all,

    I am irritated with Safari at the moment. If you incorrectly type a URL Safari saves that URL in your history. So when you go to type like macrumors.com you may also get your typo of macrummors.com.

    I want to know how to go in and just remove the one you don't want. i.e. macrummors.com

    I don't want to turn off history and I don't want to clear ALL my history and I don't want to use private browsing. I want to pick out the typos so they don't come up when I try to go to sites. I find it annoying when you are trying to go to a site and the browser wants to help you on to the wrong site.

    So anyone know how to do this? :confused:
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    History->Show All History
    Type the misspelling into the new search bar (not the google one, the one at the top of the history on the black bar)
    Click the item you want to delete
    Hit the delete key
     
  3. theelysium thread starter Suspended

    theelysium

    Joined:
    Nov 18, 2008
    #3
    Yes...

    I've tried that. It does not work. If that did I would not have made this thread.

    But, thanks.

    Anyone else have any ideas?
     
  4. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #4
    Open Safari. hen go to the Safari menu item and choose 'Reset Safari'. Just check-mark all the boxes and let it reset Safari. This should fix the problem.
     
  5. theelysium thread starter Suspended

    theelysium

    Joined:
    Nov 18, 2008
    #5
    No

    Again I don't want to reset ALL my history or lose all my Safari settings so resetting my Safari is NOT the answer. At some point there will be another typo and I'll want to remove that individual mistyped URL.

    Next.....
     
  6. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
  7. theelysium thread starter Suspended

    theelysium

    Joined:
    Nov 18, 2008
    #7
    It's in there even if you have bookmarks.

    It's also easier to type "ma"... and have all the "ma"s show up an so on.

    I also have bookmarks. The point is that there has to be a way to remove just one entry from the history list.
     
  8. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
    #8
    If you find an answer please post it, I'm not sure it can be done.
     
  9. brijazz macrumors 6502

    brijazz

    Joined:
    Jul 31, 2008
    #9
    Hmmm. Works for me, on 10.7. Be sure that you're editing your history on a screen that looks like this:

    [​IMG]
     
  10. jkantz macrumors newbie

    Joined:
    Jun 27, 2012
    #10
    There's a fairly simple solution

    Go to History > Show All History > then scroll to the offending entry and simply delete
    I was frustrated, too but knew there had to be a way. :)
     
  11. fith macrumors newbie

    Joined:
    Nov 15, 2007
    #11
    If you, like me, had full window coverflow, try dragging up from the little innocuous handle on the bottom.

    Then you should see the table view, and be able to delete your history item.

    Took me forever to notice that.
     

Share This Page