Safari input lag on 10.10

Discussion in 'OS X Yosemite (10.10)' started by thefredelement, Jan 24, 2015.

  1. thefredelement macrumors 65816

    thefredelement

    Joined:
    Apr 10, 2012
    Location:
    New York
    #1
    When I'm typing into a web form, like writing this post for instance, there is a considerable amount of input lag. Meaning the cursor will not progress forward with new characters that are typed as I'm tying them. It'll lag for a moment, then display the characters that I've typed at super speed, then be OK for a moment, then lag again.

    It only happens on Safari, only in web forms, like this forum, Amazon reviews, eBay reviews, etc.

    It's starting to drive me crazy.

    I'm using a fairly powerful Mac, (Mac Pro 4,1, 2x2.93Gz Xeons, 48Gb RAM, ATI 7970 3GB Video, 2x 256GB SSD in Raid 0)

    I've tried clearing all web data in menu > preferences, erasing the cache in ~/Library/Caches and I have no extensions installed.
     
  2. scrmtrey macrumors regular

    scrmtrey

    Joined:
    Mar 28, 2013
  3. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #3
    At this moment, it seems quite possible that's due to the HD7900 series driver. Few other HD7950 user (including myself) suffer exactly the same problem (or even worse).
     
  4. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #4
    Has anyone figured anything out yet with this? I've been suffering with this since the days of Yosemite beta... and I recently did a fresh install of 10.10.2 and it's still driving me crazy... About once every line as I'm typing the screen will just hang momentarily and then a couple seconds later it will catch up with my typing. It's horrible. And it only happens for me in Safari and only on my Mac Pro. It does not happen on my MacBook. FFS!
     
  5. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #5
    My guess would be it isn't hanging but doing somthing - is your history ok, bookmarks ok, is iCloud slow to let it talk to your iCloud bookmarks perhaps???

    Turn Safari off temporarily in iCloud and see if there is any difference?
     
  6. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #6
    I'll try that, but let's face it, nothing should be freezing it up every few moments... On a 6-Core computer no less :) It's a strange issue.
     
  7. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #7
    That is what makes me think it is an external dependency. 6-cores don't make an external lookup run any faster.
     
  8. thefredelement thread starter macrumors 65816

    thefredelement

    Joined:
    Apr 10, 2012
    Location:
    New York
    #8
    It's slightly better in 10.10.3 though not cured completely. It's still quite bothersome.

    I think it's less about lookups or anything like that and more about something with the way the this sort of input is handled (perhaps displayed) on a Mac Pro, as I mentioned I have 10.10.x on other various non Mac Pro macs and they are all fine.

    Also, on the same exact hardware I have a 10.9.4 install and that does not have the issue whatsoever. (Also with the same iCloud account, bookmarks, etc.)
     
  9. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #9
    Lots of changes came in with Yosemite to do with iCloud, same iCloud details has nothing to do with the code used, that could be quite different as as function has changed with Yosemite, quite likely to be. In contrast I can't see why a simple text input in a browser would be treated differently for an MP.
     
  10. thefredelement thread starter macrumors 65816

    thefredelement

    Joined:
    Apr 10, 2012
    Location:
    New York
    #10
    As h9826790 pointed out earlier it can be the current ATI 79x driver. It seems to effect the nMP on 10.10.x and cMP w/ ATI 79x based video cards installed.
     
  11. crjackson2134, Mar 16, 2015
    Last edited: Mar 16, 2015

    crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #11
    It does the same here too with the following video cards.

    HD 5770 (Apple Card - Default option with cMP)
    HD 5870 (Apple Card - Upgrade option with cMP)
    HD 7970 (Sapphire Reference Card - MVC Flashed)

    I've tried all my video cards and it's the same on all of them. :mad:
     
  12. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #12
    Makes you wonder if it is an AMD driver issue.

    I'm on the 10.10.3 beta and submitted a bug using Feedback Assistant... if anyone else is on the beta and has this problem, please submit a bug report.
     
  13. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #13
    Could be. I didn't have this issue in any previous version of OS X. It all started with Yosemite for me. I'm not on 10.10.3, so I can't send in a bug report for that version. I have however submitted many bug reports (feedback) on every point version of Yosemite so far.
     
  14. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #14
    Yeah, it started for me with Yosemite as well.
     
  15. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #15
    Same here, this problem only exist in Yosemite, but I didn't try my Apple 4870 yet. Even thought the 4870 work flawlessly, I won't use it due to lack of performance anyway.

    And I did submit bug report on every beta / DP, hopefully they will address this issue seriously.
     
  16. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #16
    Safari 8.04 was released a few minutes ago. It did nothing to improve the lag issue as far as I can tell.
     

Share This Page