Safari Is Still Choking!

Discussion in 'MacBook Pro' started by Doug Donut, Mar 8, 2008.

  1. Doug Donut macrumors newbie

    Jan 30, 2008
    sorry but I have lost about $3000 this week alone to Safari absolutely NOT acting like it used to. I run a record label and it's not a major.
    I've unchecked java script, checked it again. Unchecked.., (great now I can't view almost all the sites paramount to the music industry):eek:
    I have done all updates, cache, resets... Is there a TOTAL restart I have to do? I mean I am willing to revert back to Safari 1.0 fer godsakes!
    My drive and internet provider are FINE! I tested them.
    I did that DSP thing (in the network bin) and last I looked, my preference did'nt even have it like my last setting was set.

    Please, I know SOMEONE must have an idea about this.

    I basically wait six to ten times as long as I used to for internet sites to load.

    I have had my Tiger os x 4.whatever powerbook for 13 months.

    I am desparate, and I hope you can understand, Thankyou.
  2. wgilles macrumors 6502


    Feb 21, 2008
    Have you tried Firefox or some of the other open source browsers? The first two things on the page are web browsers.
  3. PorscheDude macrumors newbie

    Mar 8, 2008
    I nominate FireFox, it works very well with older computers.
  4. lofight macrumors 68000


    Jun 16, 2007
    camino is also nice, but partly eye candy too..
  5. Doug Donut thread starter macrumors newbie

    Jan 30, 2008

    still slow... It's the strangest thing! I'll try that other one... Thanks you all!:apple:
  6. virtuatony macrumors regular

    Mar 9, 2008
    Are you using Wi-Fi? or a wired connection maybe it's the router?

    I do notice with my home internet connection for some reason safari hangs on both of my newer macs for some websites when the router has a high load, the same thing happens on my windows box in firefox just less often I don't get it. Using wifi actually crashes my router, and the problem is still there with wired connections. Anyway enough about my problem I know it's the 2wire routers fault I've been though 2 of them and give up on them.

Share This Page