Safari/iTunes can't connect to web - "missing semicolon"?

Discussion in 'macOS' started by tpth, Mar 4, 2009.

  1. tpth macrumors member

    Joined:
    Oct 4, 2007
    #1
    Hey, strange problem here. Was using the Safari 4 beta happily this evening on my early 2008 MacBook Pro (running 10.5.6) - computer slept as it was on battery, and when I woke it, Safari suddenly wouldn't connect to anything at all. I reset my router and modem, as they sometimes get flaky, but this didn't fix the problem.

    On closer examination, I found that this seems to be an Apple apps problem - neither Safari, nor iTunes, nor Software Update will connect, but Firefox will (I'm using it to type this). I've tried uninstalling the beta, rolling back to an earlier build of WebKit, turning the computer on and off again. Nothing seems to help - just keep getting the same "can't connect to server" message.

    I checked Console log and found this - every time Safari opens.

    Safari[522]: CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.

    This message started appearing when the problem started.

    Ideas? Don't really want to have to archive and install unless I have to. Has anyone encountered this before?
     
  2. smknSRT8 macrumors newbie

    Joined:
    Jul 23, 2008
    #2
    I am having the similar issue where once I installed the Safari 4 Beta I couldn't log onto the internet with Safari 4 and Firefox. I uninstalled it and it and the old Safari worked.

    EDIT:::just uninstalled it and reinstalled it and it works flawlessly. I love it!
     

Share This Page