Safari Keeps Locking Up On New 17" UMBP!

Discussion in 'Mac Basics and Help' started by Bazzy, Jul 10, 2009.

  1. Bazzy macrumors regular

    Joined:
    Jun 8, 2009
    #1
    Hi All,

    I just got a brand new 17" UBMP and when using Safari 4.0.1, I get lots of lock ups with spinning wheels. It happens when just surfing the web & every time so far when trying to put characters in the search bar in the bookmarks page.

    The system does not allow me to do force quit at the apple logo nor on the application logo - I can go in Activity Monitor where it says, "Safari Not Responding" and I then quit the process.

    Can anyone tell me why this is happening and how to fix it? It is driving me nuts and I was not expecting it on the latest top end Apple machine running the latest versions of Apple's own software!!

    Many Thanks!

    Bazzy!
     
  2. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #2
    Have you tried resetting Safari under the Safari Menu?

    Woof, Woof - Dawg [​IMG]
     
  3. Bazzy thread starter macrumors regular

    Joined:
    Jun 8, 2009
    #3
    Hi,

    Yep, tried that but know the spinning wheels occur regardless of what is being done ans things are kind of choppy with delays in commands?

    Bazzy!
     

Share This Page