Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

carlob

macrumors regular
Original poster
Nov 23, 2014
146
75
On my 16" M1 MacBook Pro the browser goes back a page on its own and when I go forward to bring back the page I was reading it does nothing, like it doesn't exist. Also it randomly reloads pages. This is very very annoying.
 
  • Like
Reactions: planetf1

Zippy1

macrumors newbie
Dec 30, 2021
2
0
I'm having the same issue with Safari going back a page. Very annoying.

Also have a 16" M1 MacBook Pro.
 
Last edited:

carlob

macrumors regular
Original poster
Nov 23, 2014
146
75
I'm having the same issue with Safari going back a page. Very annoying.

Also have a 16" M1 MacBook Pro.
I was able to track it down to tab groups, seems that it happens only in a tab group window.
 

Zippy1

macrumors newbie
Dec 30, 2021
2
0
I was able to track it down to tab groups, seems that it happens only in a tab group window.
Thanks. I’ll have to try that. That’s unfortunate since I use Tab Groups all the time and where I was seeing the issue was definitely in a Tab Group.

Update: After using Safari for an hour or so I would agree the fix is related to Tab Groups. When I use Safari without browsing a site in a Tab Group.....it is rock solid.
 
Last edited:

doolar

macrumors 6502
Nov 25, 2019
377
662
I just talked about how I never noticed any major issues in Safari in another thread, but I have the exact same problem too in Tab Groups. Not major of course, but I do hope it'll be fixed in an update soon. Using a 14" M1 Pro and a M1 Air, same on both machines.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.