Safari lagging when typing

wfoster

macrumors 6502a
Original poster
Feb 16, 2009
696
37
Plymouth, UK
I'm currently using a brand new iPad 2 and iPhone 4S with the latest software. For some reason, Safari keeps lagging whenever I type in the address bar. Not sure what to do? Tried most things apart from restoring.

Thanks,
W.

Issue has been resolved, turning off the bookmarks in iCloud.
 
Last edited:

LeeM

macrumors 6502a
Jan 1, 2012
603
0
Not completely helpful but get iCab off the app store. It's a much better browser for the iPad. For a start it doesn't refresh tabs every time you switch.
As far as lagging is concerned I get the same with my iPhone 4, never noticed it on the iPad (both 5.0.1)
 

wfoster

macrumors 6502a
Original poster
Feb 16, 2009
696
37
Plymouth, UK
Are you syncing your bookmarks through iCloud? If so disable it and you should good to go.
Turning off my bookmarks via iCloud is proving to be a challenge. It tells me it's deleting bookmarks but it just hangs..

Not completely helpful but get iCab off the app store. It's a much better browser for the iPad. For a start it doesn't refresh tabs every time you switch.
As far as lagging is concerned I get the same with my iPhone 4, never noticed it on the iPad (both 5.0.1)
I will take a look at this, thanks Lee.
 

rocknblogger

macrumors 68020
Apr 2, 2011
2,331
414
New Jersey
Turning off the bookmarks finally worked. I really appreciate it!
I had a lot of bookmarks so I assume it's the amount of bookmarks rather than the actual sync that's the problem. I'm assuming someone who has very few bookmarks may not be affected by this.
 

Ecoh

macrumors 6502a
Oct 30, 2009
651
23
USA
Thanks for the tip !

I have about 300 bookmarks on my iPad2, no problems at all. But on my fathers iPad 1, he has similar amount of bookmarks, turning off bookmark syncing
greatly improved typing response.
 

LeeM

macrumors 6502a
Jan 1, 2012
603
0
Bookmarks explains why I've had the problem on my phone and not the pad, pads always connected to a faster wifi connection