Safari launching too slowly?

Discussion in 'Mac Basics and Help' started by Mjmar, Jul 9, 2009.

  1. Mjmar macrumors 65816

    Joined:
    May 20, 2008
    #1
    I'm using a 2.4GHz MacBook, and Safari 4 takes 20-25 seconds too open up... Does it take that long for you? It's weird because no other application that I have takes even close to that long to open.
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    Are you opening Top Sites at launch? That slows it down a lot. Personally, I hate the feature.
     
  3. Mjmar thread starter macrumors 65816

    Joined:
    May 20, 2008
    #3
    It opens to Yahoo, but for some reason it just takes forever. Safari 3 was much faster at launch.
     
  4. keithOrbit macrumors member

    Joined:
    Apr 22, 2008
    #4
    open applications-->utilities-->Disk utility, repair disk permissions.
     
  5. eleven7 macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #5
    There's something definitely wrong there. My safari loads in a second or two. Even from a cold start.
     
  6. upinflames900 macrumors 6502a

    upinflames900

    Joined:
    May 20, 2009
    #6
    updates and reinstall safari...those are the only two things that come to mind immediately...what is your internet connection speed though?
     
  7. Nocturnal22 macrumors 6502

    Joined:
    Feb 23, 2009
    #7
    plus if you have a slower HDD it will open slower
     
  8. Mjmar thread starter macrumors 65816

    Joined:
    May 20, 2008
    #8
    Is there any possibility of a virus? Now that I think about it my Mac doesn't feel as snappy as it has been in the past.... Could be because the hard drive is nearly full though.
     

Share This Page