Safari loading pages slowly, but internet connection's fine

Discussion in 'Mac Basics and Help' started by Bendy Walker, Mar 18, 2009.

  1. Bendy Walker macrumors regular

    Bendy Walker

    Joined:
    Jan 29, 2008
    Location:
    Manchester, UK
    #1
    Hey there guys.

    For about a week or so now, my Safari has been loading webpages incredibly slowly. It will often display the message 'server cannot be found/reached'.

    I have absolutely no idea what's causing this. I know it's not my actual connection, because I can play World of Warcraft with an average latency of 60ms, and direct download large files at a speed I expect.

    Any suggestions as to what's causing this/how to fix it?

    Thanks :)
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Check the DNS server settings in your Network Preferences. And make sure you don't have a proxy enabled if you don't need to.
     
  3. Bendy Walker thread starter macrumors regular

    Bendy Walker

    Joined:
    Jan 29, 2008
    Location:
    Manchester, UK
    #3
    Don't have a proxy enabled. DNS settings seem to be in order =/
     
  4. Matari macrumors member

    Joined:
    Oct 30, 2007
    #4
    Same problem with Safari

    I have noticed how slow Safari has suddenly become in the last week or so - my internet connection is also fine, so I know it isn't that. Anyone got any ideas - getting annoying.
     
  5. brian2220 macrumors member

    brian2220

    Joined:
    Aug 20, 2008
    Location:
    Phoenix,AZ USA
    #5
    its in beta
    its still being worked out
     

Share This Page