Safari logging me out of Facebook

Discussion in 'Mac Basics and Help' started by KaPOWitsCHRIS, Jul 25, 2012.

  1. KaPOWitsCHRIS macrumors 6502

    KaPOWitsCHRIS

    Joined:
    Apr 8, 2010
    Location:
    Coventry, UK
    #1
    Despite the fact I have the "keep me logged in" box checked on Safari and cookies enabled for always, whenever I restart my computer it seems to log me out of Facebook. Now, it won't even log into Facebook.

    Help?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Clear your browser's cache and cookies and try again.
     
  3. KaPOWitsCHRIS thread starter macrumors 6502

    KaPOWitsCHRIS

    Joined:
    Apr 8, 2010
    Location:
    Coventry, UK
    #3
    I have done several times - still happens.

    I must correct my first post, I have the setting for blocking cookies set to "never"

    It's letting me log in now however
     
  4. scottfreeman macrumors newbie

    scottfreeman

    Joined:
    Jul 27, 2012
    Location:
    UK
    #4
    I keep getting the same. Both Facebook and Twitter seem to log me out randomly, sometimes while even actively using the site.

    Twitter never seems to save my login information between sessions, and Facebook seems 1 out of 3 times I'm logged out.

    Emptied everything in Safari - history, cookies, saved information - but it's still happening.
     
  5. TheWelshBoyo macrumors 6502

    Joined:
    Dec 14, 2008
    Location:
    Cardiff, Wales
    #5
    Same thing's been happening to me since before I upgraded to Mountain Lion, before I upgraded to Safari 6 on Lion. I've deleted all passwords, erased Chrome using App Cleaner etc. to no avail.
     
  6. scottfreeman macrumors newbie

    scottfreeman

    Joined:
    Jul 27, 2012
    Location:
    UK
    #6
    Fixed!

    Fixed the Safari logging out of Facebook problem!

    Go to your Facebook account in a different browser.
    Click on the down arrow in the top right of Facebook, on the blue bar
    Click on Account Settings
    Click on Apps in the side bar
    Find Skype in the list, and delete it

    This worked for me. Facebook has been logged in with Safari for over an hour, a new record!!
     
  7. KaPOWitsCHRIS, Jul 29, 2012
    Last edited: Jul 30, 2012

    KaPOWitsCHRIS thread starter macrumors 6502

    KaPOWitsCHRIS

    Joined:
    Apr 8, 2010
    Location:
    Coventry, UK
    #7
    Thanks, I'll give it a try and report back with my results!

    Edit:

    It seems to have fixed it, thanks!
     

Share This Page