Safari massive CPU hog

sziehr

macrumors 6502a
Original poster
Jun 11, 2009
666
485
so while running safari it has a helper running called safari networking it using 99 to 100 cpu even when no browser window is open. I have reported this bug. But i was wondering if any one else has this issue or if i am alone.
 

mrapplegate

macrumors 68030
Feb 26, 2011
2,818
8
Cincinnati, OH
so while running safari it has a helper running called safari networking it using 99 to 100 cpu even when no browser window is open. I have reported this bug. But i was wondering if any one else has this issue or if i am alone.
Nope. Safari Networking on mine is 0.0% , obviously nothing near your 99%
 

sziehr

macrumors 6502a
Original poster
Jun 11, 2009
666
485
I made a fresh account it seems to be perfectly fine in the new account. This is tied to a faulty setting brought over with the upgrade instresting.
 

Distearth

macrumors newbie
May 6, 2008
18
0
Mine just started

Mine went to 99 just yesterday and I've been running 10.9 since release. Any fix besides new account yet?
 

t-rexosaur

macrumors newbie
Oct 30, 2013
1
0
This worked for me.

I tried deleting all my data from safari, but it didn't seem to fix it. I looked in the activity monitor to find out where the files the Safari Networking was hiding it's plists and I found them in:
/Users/t-rexosaur/Library/Caches/com.apple.Safari/fsCachedData/
I moved all the files to my desktop to be sure it was okay and It stopped the problem and now everything is back to normal. I deleted all the files since. Everything is working fine.

Sounds like a bad file stuck in your cached data. Hope this works for everyone else.
 

Wiltowonga

macrumors newbie
Nov 13, 2013
1
0
Also a Problem for me

Thanks t-rexosaur

This problem 'chewed-up' 4GB of my small monthly broadband allowance before I tracked it down and cleared the caches.

A great help.
 

shashank85

macrumors newbie
Nov 15, 2013
1
0
Clear cache from within Safari

Enable 'Develop' mode in Safari (Safari -> Preferences -> Advanced -> check 'Show Develop menu in menu bar')

Under 'Develop' menu option, click on 'Empty Caches'
 

Intelligent

macrumors 6502a
Aug 7, 2013
923
2
I tried deleting all my data from safari, but it didn't seem to fix it. I looked in the activity monitor to find out where the files the Safari Networking was hiding it's plists and I found them in:
/Users/t-rexosaur/Library/Caches/com.apple.Safari/fsCachedData/
I moved all the files to my desktop to be sure it was okay and It stopped the problem and now everything is back to normal. I deleted all the files since. Everything is working fine.

Sounds like a bad file stuck in your cached data. Hope this works for everyone else.
This fixed it for me but do you know what gets deleted with this cache?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.