Safari Missing Java

Discussion in 'Mac Apps and Mac App Store' started by Merkava_4, Dec 22, 2011.

  1. Merkava_4, Dec 22, 2011
    Last edited: Dec 22, 2011

    Merkava_4 macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
    #1
    Mac 10.6.8
    Safari 5.1.2

    Hi all :)

    My Safari browser is missing Java. This happened all of a sudden last night. I'm writing this with Camino because the forum reply buttons and quote buttons are missing with Safari. Same story with other forums I visit. I've got Java enabled in Safari Preferences. Here are some screen shots below. You can click on the images to make them full size:

    Google Home Page (Safari):
    [​IMG]

    Google Home Page (Camino):
    [​IMG]

    Google News Page (Safari):
    [​IMG]

    Google News Page (Camino):
    [​IMG]

    Safari Preferences (Security):
    [​IMG]
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Have you opened your Java Preferences application in /Applications/Utilities and poked around? Did you have the checkmark next to "Enable applet plug-in and Web Start applications" filled in under the General tab? How about in the list below there? Also check in the Advanced tab as well.
     
  3. Merkava_4 thread starter macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
    #3
    Hi JediMeister :)

    This is what I have checked in Java Preferences:

    [​IMG]

    [​IMG]
     
  4. Mikey7c8 macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Montreal, Canada
    #4
    Google not showing images is unlikely to be Java - what makes you think it is?

    Clear your cache, cookies etc and restart.
     
  5. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #5
    I don't think any of that has anything to do with Java - Javascipt perhaps, but not Java.

    Do you have any plugins intended to block ads or such? Maybe disable your plugins and see if the problem goes away.
     
  6. Merkava_4 thread starter macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
    #6
    Isn't Java what makes words and buttons appear on the page? I've cleared all cookies and reset Safari many many times, still no change. Thanks for your help. :)

    I actually don't know the difference between Java and Javescript. I'm just an average computer user; no where near an expert. How would I disable my plugins?
     
  7. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #7
    No.

    Two unrelated languages - just sound the same.

    Safari->Preferences-> Extensions Tab
    THere is a switch at the top to disable all plugins, or there is an uninstall button next to each plugin.
     
  8. Merkava_4 thread starter macrumors 6502a

    Joined:
    Sep 4, 2010
    Location:
    California
    #8
    Hi Scooby,

    I got it fixed. I had to completely delete Safari and then download a new one. The trick was finding out how to get rid of the old Safari all the way without leaving any traces of it behind; but I got it.

    Thanks very much for your help. :)
     

Share This Page