Safari missing plug-ins

Discussion in 'OS X El Capitan (10.11)' started by Slevin, Sep 28, 2015.

  1. Slevin macrumors regular

    Joined:
    Jul 1, 2007
    Location:
    New York
    #1
    I've had this issue for awhile but it's really starting to bug me. Ever since I deleted flash from my system youtube has consistently told me that I'm missing a plugin whenever I attempt to view an embedded video on a different site or on the main site. So I'd have to fire up chrome and watch the video there. I'd prefer not to reinstall flash so is there a solution that anyone knows about?
     
  2. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #2
    Some Youtube videos are only presented in Flash. If you want to watch the video, you either need to install flash, or use a browser like Chrome that has flash built in.

    If you don't install flash or use a browser with flash built in, then you can't watch Flash videos.
     
  3. Slevin thread starter macrumors regular

    Joined:
    Jul 1, 2007
    Location:
    New York
    #3
    It's not just some, it's all videos that I attempt to watch that use flash
     
  4. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #4
    Then it makes sense that you can't watch them.
     
  5. Slevin thread starter macrumors regular

    Joined:
    Jul 1, 2007
    Location:
    New York
    #5
    But then is should allow the video to play in HTML5
     
  6. Autistic Behaviour macrumors member

    Autistic Behaviour

    Joined:
    Sep 9, 2015
    Location:
    montreal
    #6
    I use the extension clicktoflash, so, whenever a HTML5 video is available, thats what safari uses. All the youtube videos I've tried play in HTML5. I do have flash installed (for other sites), but I believe you should be able to watch any youtube video in HTML5. You could right click on a video in youtube and check the settings, maybe....
     

Share This Page